[gelöst] Keine Updates wegen Schlüsselproblem Thema ist als GELÖST markiert

User helfen sich hier bei der Manjaro XFCE Edition!
Antworten

Themen Author
Die_Kralle
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 54
Registriert: Donnerstag 26. Januar 2023, 21:38
CPU: Intel Core i7-4700HQ
GPU: Mesa Intel HD Graphics 4600 (1,5 GiB)
Kernel: 6.0.19-3-MANJARO
Desktop-Variante: XFCE
GPU Treiber: 390xx-bumblebee
Hat sich bedankt: 24 Mal

[gelöst] Keine Updates wegen Schlüsselproblem

#1

Beitrag von Die_Kralle »

Manjaro XFCE 23.1.0 - Kernel 6.5.11-1

Moin,

heute meldete der Paket-Manager viele zur Verfügung stehende Updates.
Diese werde auch heruntergeladen, aber dann bricht die Installation einfach ab.

Wenn ich die Installation über das Terminal probiere,

Code: Alles auswählen

sudo pacman -Syu

Code: Alles auswählen

sudo pacman -Syu
[sudo] Passwort für heiko: 
:: Paketdatenbanken werden synchronisiert …
 core ist aktuell
 extra ist aktuell
 multilib ist aktuell
:: Vollständige Systemaktualisierung wird gestartet …
Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: mhwd-nvidia wird vor seiner Abhängigkeit mhwd installiert werden
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: mhwd-db wird vor seiner Abhängigkeit mhwd installiert werden
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: mhwd-db wird vor seiner Abhängigkeit mhwd installiert werden

Pakete (86) android-tools-34.0.4-3  android-udev-20231104-1
            btrfs-progs-6.6.1-1  enchant-2.6.2-1  exiv2-0.28.1-1
            fakeroot-1.32.2-1  filezilla-3.66.1-1  firefox-119.0.1-1
            firefox-i18n-de-119.0.1-1  firefox-i18n-en-us-119.0.1-1
            gawk-5.3.0-1  ghostscript-10.02.1-1  gimp-2.10.36-1  git-2.42.1-1
            gssdp-1.6.3-1  gufw-24.04-1  gupnp-1:1.6.6-1  hwdata-0.376-1
            iproute2-6.6.0-2  kdialog-23.08.3-1  lib32-libelf-0.190-1
            lib32-p11-kit-0.25.2-1  lib32-sdl2-2.28.5-1  lib32-xz-5.4.5-1
            libcloudproviders-0.3.5-1  libelf-0.190-1  libgsf-1.14.51-1
            libheif-1.17.3-1  libimagequant-4.2.2-1  libp11-kit-0.25.2-1
            libpipewire-1:0.3.84-1  libreoffice-still-7.5.8-1
            libreoffice-still-de-7.5.8-1  libsndfile-1.2.2-2  libuv-1.47.0-1
            libvips-8.14.5-2  linux-firmware-20231030.2b304bfe-1
            linux-firmware-whence-20231030.2b304bfe-1  linux65-6.5.11-1
            linux65-bbswitch-0.8-24  linux65-broadcom-wl-6.30.223.271-24
            linux65-headers-6.5.11-1  linux65-nvidia-390xx-390.157-16
            luajit-2.1.1699392533-1  mhwd-0.6.5-28  mhwd-db-0.6.5-28
            mhwd-nvidia-535.129.03-2  node-gyp-10.0.1-1  nodejs-21.1.0-1
            noto-fonts-1:23.11.1-1  npm-10.2.3-2  p11-kit-0.25.2-1
            papirus-icon-theme-20231101-1  pipewire-1:0.3.84-1
            polkit-qt5-0.175.0-1  protobuf-25.0-1  protobuf-c-1.4.1-5
            python-charset-normalizer-3.3.2-1  python-pillow-10.1.0-1.0
            python-pydantic-2.4.2-1  python-pydantic-core-1:2.10.1-1
            qt6-base-6.6.0-3  re2-1:20231101-1  sdl2-2.28.5-1  semver-7.5.4-1
            shadow-4.14.2-1  signal-desktop-6.38.0-1  sof-firmware-2023.09.1-1
            spdlog-1.12.0-2  sqlite-3.44.0-1  sudo-1.9.15.p2-1
            suitesparse-7.3.1-1  telegram-desktop-4.11.6-1
            thin-provisioning-tools-1.0.7-1  thunar-archive-plugin-0.5.2-1
            thunderbird-115.4.2-1  thunderbird-i18n-de-115.4.2-1
            thunderbird-i18n-en-us-115.4.2-1  usbutils-017-1
            util-linux-2.39.2-2  util-linux-libs-2.39.2-2  vlc-3.0.20-2
            wine-8.19-1  wine-mono-8.1.0-1  xfconf-4.18.3-1  xz-5.4.5-1

Gesamtgröße der installierten Pakete:  3854,46 MiB
Größendifferenz der Aktualisierung:      35,32 MiB

dann erfahre ich, das es Probleme mit den Keys gibt.

Code: Alles auswählen

:: Installation fortsetzen? [J/n] j
(86/86) Schlüssel im Schlüsselbund werden geprüft  [######################] 100%
Benötigte Schlüssel werden heruntergeladen …
:: PGP Schlüssel 7A4E76095D8A52E4, »Antonio Rojas <arojas@archlinux.org>« importieren? [J/n] j
Fehler: Schlüssel "7A4E76095D8A52E4" konnte nicht importiert werden
:: PGP Schlüssel 9B7A287D9A2EC608, »David Runge <dvzrv@archlinux.org>« importieren? [J/n] j
Fehler: Schlüssel "9B7A287D9A2EC608" konnte nicht importiert werden

Und so geht das für jede Datei.


Die Typs die man das zu findet, sind alle älter und die genutzten Parameter teilweise nicht mehr vorhanden.

Wie repariere den Keyring und die Keys?

Gruß Heiko
Zuletzt geändert von Die_Kralle am Mittwoch 15. November 2023, 22:03, insgesamt 1-mal geändert.
Benutzeravatar

ManTuxer
Forum Kenner
Forum Kenner
Beiträge: 169
Registriert: Donnerstag 19. August 2021, 08:29
CPU: Intel Core i7-9750H
GPU: NVIDIA GeForce GTX 1650 Mobile / Intel
Kernel: aktuellsten nicht RC + LTS (fallback)
Desktop-Variante: Cinnamon
GPU Treiber: NVIDIA
Hat sich bedankt: 35 Mal
Danksagung erhalten: 45 Mal

Re: Keine Updates wegen Schlüsselproblem

#2

Beitrag von ManTuxer »

Die Keyrings neu zu erstellen sollte helfen:

Code: Alles auswählen

sudo pacman -S  manjaro-keyring archlinux-keyring

Themen Author
Die_Kralle
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 54
Registriert: Donnerstag 26. Januar 2023, 21:38
CPU: Intel Core i7-4700HQ
GPU: Mesa Intel HD Graphics 4600 (1,5 GiB)
Kernel: 6.0.19-3-MANJARO
Desktop-Variante: XFCE
GPU Treiber: 390xx-bumblebee
Hat sich bedankt: 24 Mal

Re: Keine Updates wegen Schlüsselproblem

#3

Beitrag von Die_Kralle »

Moin,

hat leider nicht funktioniert:

Code: Alles auswählen

sudo pacman -S  manjaro-keyring archlinux-keyring
[sudo] Passwort für heiko: 
Warnung: manjaro-keyring-20230719-2 ist aktuell -- Reinstalliere
Warnung: archlinux-keyring-20231107-1 ist aktuell -- Reinstalliere
Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …

Pakete (2) archlinux-keyring-20231107-1  manjaro-keyring-20230719-2

Gesamtgröße des Downloads:             1,22 MiB
Gesamtgröße der installierten Pakete:  1,72 MiB
Größendifferenz der Aktualisierung:    0,00 MiB

:: Installation fortsetzen? [J/n] j
:: Pakete werden empfangen …
 archlinux-keyrin...  1169,5 KiB  4,44 MiB/s 00:00 [######################] 100%
 manjaro-keyring-...    84,7 KiB  3,06 MiB/s 00:00 [######################] 100%
 Gesamt (2/2)         1254,1 KiB  3,57 MiB/s 00:00 [######################] 100%
(2/2) Schlüssel im Schlüsselbund werden geprüft    [######################] 100%
Benötigte Schlüssel werden heruntergeladen …
:: PGP Schlüssel CAA6A59611C7F07E, »Philip Müller <philm@manjaro.org>« importieren? [J/n] j
Fehler: Schlüssel "CAA6A59611C7F07E" konnte nicht importiert werden
Fehler: Erforderlicher Schlüssel fehlt im Schlüsselbund
Fehler: Der Vorgang konnte nicht durchgeführt werden (Unerwarteter Fehler)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Und nun?

Gruß Heiko
Benutzeravatar

country
Forum Held
Forum Held
Beiträge: 997
Registriert: Samstag 16. Oktober 2021, 02:12
CPU: Ryzen 7 3700X
GPU: RTX 3060Ti
Kernel: up-to-date
Desktop-Variante: Cinnamon
GPU Treiber: RTX 3060Ti
Hat sich bedankt: 113 Mal
Danksagung erhalten: 186 Mal

Re: Keine Updates wegen Schlüsselproblem

#4

Beitrag von country »

Ales als sudo ausführen.

Code: Alles auswählen

rm -r /etc/pacman.d/gnupg/
pacman-key --init

pacman-key --refresh-keys 
pacman-key --populate archlinux manjaro
pacman -Sc
wenn das auch nicht geht bemüh dich mal mit der suchmaschine.

Themen Author
Die_Kralle
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 54
Registriert: Donnerstag 26. Januar 2023, 21:38
CPU: Intel Core i7-4700HQ
GPU: Mesa Intel HD Graphics 4600 (1,5 GiB)
Kernel: 6.0.19-3-MANJARO
Desktop-Variante: XFCE
GPU Treiber: 390xx-bumblebee
Hat sich bedankt: 24 Mal

Re: Keine Updates wegen Schlüsselproblem

#5

Beitrag von Die_Kralle »

Moin,
country hat geschrieben: Mittwoch 15. November 2023, 18:40 Ales als sudo ausführen.

Code: Alles auswählen

rm -r /etc/pacman.d/gnupg/
pacman-key --init

pacman-key --refresh-keys 
pacman-key --populate archlinux manjaro
pacman -Sc
wenn das auch nicht geht bemüh dich mal mit der suchmaschine.
Danke, danach funktioniert es wieder.
Ich hatte vor dem Post mittels Suchmaschine gesucht, aber bei den Tipps, sollte man auch eine Reihe von Terminal-Befehlen eingeben und immer war ein Befehl dabei, wo der geforderte Parameter als unbekannt bemängelt wurde.
Da mein Englisch ein dem Bereich nicht so gut ist, fehlten mir wahrscheinlich die richtig Suchbegriffe.

Gruß Heiko
Antworten