Nach Manjaro-Update vom 21.07.2022: VirtualBox - es startet keine VM mehr Thema ist als GELÖST markiert

Fragen und Support zur Virtualisierung......
Antworten

Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 232
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.10
Desktop-Variante: XFCE
GPU Treiber: nVidia proprietär
Hat sich bedankt: 59 Mal
Danksagung erhalten: 4 Mal
Kontaktdaten:

Nach Manjaro-Update vom 21.07.2022: VirtualBox - es startet keine VM mehr

#1

Beitrag von Clemens »

Nachdem relativ lange meine Windows-7 VMs in der Virtualbox problemlos gelaufen sind, lässt sich nun keine mehr starten. Ebenfalls lässt sich keine Manjaro-VM mehr starten. Bei allen erhalte ich die gleichen Fehlermeldungen und die gleichen Angaben als letzte Zeile vor dem Abbruch im LogFile der Virtualbox. Daher muss ich davon ausgehen, dass der Fehler im VirtualBox-System liegt.

Die installierte Version der VB ist 6.1.36-1

Jeder Startversuch bricht ab mit:

Code: Alles auswählen

Für die virtuelle Maschine Win-7 Home Premium konnte keine neue Sitzung eröffnet werden.
The VM-session was aborted.

Fehlercode: 
NS_ERROR_FAILURE (0x80004005)
Komponente: 
SessionMachine
Interface: 
ISession {c0447716-ff5a-4795-b57a-ecd5fffa18a4}
Im Logfile, das die Virtualbox erzeugt, findet sich als letzte Zeile jeweils:

Code: Alles auswählen

00:00:01.122017 SUP: Loaded VBoxEhciR0.r0 (/usr/lib/virtualbox/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/linux.amd64/VBoxEhciR0.r0) at 0xXXXXXXXXXXXXXXXX - ModuleInit at XXXXXXXXXXXXXXXX and ModuleTerm at XXXXXXXXXXXXXXXX
Die Manjaro-VM hatte ich vor ca. 14 Tagen zuletzt benutzt.
Die VM mit Win-7 hatte ich zuletzt vor etwa 1 Woche benutzt. Darin läuft die komplette Adobe-CS-6 Suite. Jetzt benötige ich genau diese Software dringend!

Was tun?
Benutzeravatar

Blueriver
Moderator
Moderator
Beiträge: 2290
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.15
Desktop-Variante: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 23 Mal
Danksagung erhalten: 118 Mal

Re: Nach Manjaro-Update vom 21.07.2022: VirtualBox - es startet keine VM mehr

#2

Beitrag von Blueriver »

Clemens hat geschrieben: Montag 25. Juli 2022, 13:23 Die installierte Version der VB ist 6.1.36-1
Bist du sicher, die aktuelle VB Version im stable ist 6.1.34-4.
Das Extension Pack aus dem AUR ist 6.1.36-1.

Du musst also die Versionen angleichen.
Entweder das Extension Pack aus dem AUR downgraden oder die VM aus dem Testing upgraden.
Nach einem Neustart sollte es dann wieder funktionieren.

Du kannst dir aber auch mal das hier aus dem englischen Forum durchlesen.
https://forum.manjaro.org/t/stable-upda ... /117185/10
Benutzeravatar

country
Forum Held
Forum Held
Beiträge: 605
Registriert: Samstag 16. Oktober 2021, 02:12
CPU: AMD Ryzen 7 3700X
GPU: GeForce RTX 3060Ti
Kernel: 5.18
Desktop-Variante: KDE Plasma
GPU Treiber: NVIDIA 515
Hat sich bedankt: 65 Mal
Danksagung erhalten: 99 Mal

Re: Nach Manjaro-Update vom 21.07.2022: VirtualBox - es startet keine VM mehr

#3

Beitrag von country »

oder du schaust dir an wie es siliziumfuchs gemacht hat..
viewtopic.php?p=28327#p28327

etwas weiter unten ist die Lösung

Themen Author
Clemens
Forum Kenner
Forum Kenner
Beiträge: 232
Registriert: Donnerstag 9. Januar 2020, 18:16
Wohnort: Rottweil
CPU: Intel i5-7400
GPU: nVidia GTX 1650
Kernel: 5.10
Desktop-Variante: XFCE
GPU Treiber: nVidia proprietär
Hat sich bedankt: 59 Mal
Danksagung erhalten: 4 Mal
Kontaktdaten:

Re: Nach Manjaro-Update vom 21.07.2022: VirtualBox - es startet keine VM mehr

#4

Beitrag von Clemens »

Danke für die guten Anregungen.

Ich habe im Vertrauen darauf, dass das ExtensionPack in der richtigen Version 6.1.34 im "stable"-Repo liegt, die AUR Version deinstalliert und dann über Pamac die 6.1.34 zu finden versucht. Nix da! Es wird immer nur die 6.1.36 im AUR angeboten.

Tipp für alle hier:
Zuerst das unpassende Pack deinstallieren, entweder per Pamac oder im Terminal mit

Code: Alles auswählen

sudo VBoxManage extpack uninstall "Oracle VM VirtualBox Extension Pack" 
Dann von der Oracle Website das passende Pack herunter laden

Code: Alles auswählen

https://download.virtualbox.org/virtualbox/6.1.34/Oracle_VM_VirtualBox_Extension_Pack-6.1.34.vbox-extpack
und aus dem Download-Verzeichnis ins /home geschoben.

Danach habe ich im Terminal ausgeführt:

Code: Alles auswählen

sudo vboxmanage extpack install Oracle_VM_VirtualBox_Extension_Pack-6.1.34.vbox-extpack
Alle VMs starten jetzt wieder auf Anhieb einwandfrei. Das von vorigen Versuchen her stammende rote "abgebrochen" in der VirtualBox Verwaltung kann man ignorieren und einfach die VM starten.

Ich erinnere mich, dass ich ein ähnliches Problem schon mal hatte und so gelöst hatte. Aktuell war ich lediglich verwirrt darüber, dass ich keinen Hinweis darauf vorliegen hatte, dass die in AUR angebotene Version nicht zu der Version der standardmäßig installierten VBox aus den normalen Repos passen würde.
Antworten

Zurück zu „Manjaro Linux Virtualisierung“