Problem mit lightdm Thema ist als GELÖST markiert

Die grandiose Manjaro Cinnamon Edition ist hier die Diskussionsplattform
Antworten

Themen Author
kroschi
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 4
Registriert: Samstag 14. August 2021, 17:25
CPU: Intel Core i3-7300T
GPU: Intel HD Graphics 630
Kernel: 5.10.56-1-MANJARO x86_64
Desktop-Variante: Cinnamon 5.0.5
GPU Treiber: i915
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Problem mit lightdm

#1

Beitrag von kroschi »

Hallo liebe Leute,

ich habe Manjaro neu aufgesetzt und jetzt komme ich beim Starten nur manchmal ins Anmeldefenster. hier die Ausgabe von systemctl status lightdm:

Code: Alles auswählen

lightdm.service - Light Display Manager
     Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Sun 2022-06-19 10:47:24 CEST; 2h 2min ago
   Duration: 19ms
       Docs: man:lightdm(1)
    Process: 520 ExecStart=/usr/bin/lightdm (code=exited, status=1/FAILURE)
   Main PID: 520 (code=exited, status=1/FAILURE)
        CPU: 57ms

Jun 19 10:47:24 frankw systemd[1]: lightdm.service: Scheduled restart job, restart counter is at 5.
Jun 19 10:47:24 frankw systemd[1]: Stopped Light Display Manager.
Jun 19 10:47:24 frankw systemd[1]: lightdm.service: Start request repeated too quickly.
Jun 19 10:47:24 frankw systemd[1]: lightdm.service: Failed with result 'exit-code'.
Jun 19 10:47:24 frankw systemd[1]: Failed to start Light Display Manager.
hier noch inxi -Fz

Code: Alles auswählen

System:
  Kernel: 5.15.48-1-MANJARO arch: x86_64 bits: 64 Desktop: Cinnamon v: 5.2.7
    Distro: Manjaro Linux
Machine:
  Type: Desktop Mobo: Micro-Star model: PRO Z690-P DDR4 (MS-7D36) v: 2.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: A.00
    date: 10/15/2021
CPU:
  Info: quad core model: 12th Gen Intel Core i3-12100T bits: 64 type: MT MCP
    cache: L2: 5 MiB
  Speed (MHz): avg: 600 min/max: 800/5300 cores: 1: 600 2: 600 3: 600
    4: 600 5: 600 6: 600 7: 600 8: 600
Graphics:
  Device-1: Intel driver: i915 v: kernel
  Device-2: Conexant Systems CX23887/8 PCIe Broadcast Audio and Video
    Decoder with 3D Comb
    driver: cx23885 v: 0.0.4
  Device-3: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo
  Display: server: X.Org v: 21.1.3 driver: X: loaded: modesetting gpu: i915
    resolution: 1920x1080~60Hz
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Alder Lake-S HD Audio driver: snd_hda_intel
  Device-2: Conexant Systems CX23887/8 PCIe Broadcast Audio and Video
    Decoder with 3D Comb
    driver: cx23885
  Device-3: Thesycon System & Consulting GmbH E50 type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Device-4: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo
  Sound Server-1: ALSA v: k5.15.48-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 16.0 running: yes
  Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Realtek RTL8125 2.5GbE driver: r8169
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 9.55 TiB used: 2.28 TiB (23.9%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 500GB
    size: 465.76 GiB
  ID-2: /dev/sda vendor: Western Digital model: WD40EFRX-68N32N0
    size: 3.64 TiB
  ID-3: /dev/sdb vendor: Western Digital model: WD60EFZX-68B3FN0
    size: 5.46 TiB
Partition:
  ID-1: / size: 457.09 GiB used: 17.59 GiB (3.8%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 3.58 TiB used: 2.27 TiB (63.3%) fs: ext4 dev: /dev/sda1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 40.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 255 Uptime: 2h 10m Memory: 15.43 GiB used: 2.19 GiB (14.2%)
  Shell: Bash inxi: 3.3.19
Hat jemand vielleicht eine Idee, wie ich das Problem lösen kann?

mit freundlichen Grüßen
kroschi
Benutzeravatar

Manfrago
Forum Held
Forum Held
Beiträge: 1364
Registriert: Dienstag 8. Dezember 2020, 17:23
Wohnort: Lubeca
CPU: i5 und i7 Gen 3 bis 7
GPU: Intel / Nvidia
Kernel: 5.4 / 5.10
Desktop-Variante: XFCE/Cinnamon
GPU Treiber: Nvidia-390xx / Optimus qt
Hat sich bedankt: 37 Mal
Danksagung erhalten: 241 Mal

Re: Problem mit lightdm

#2

Beitrag von Manfrago »

Herzlich willkommen im Forum.
Eine Lösung besteht eventuell darin, logind-check-graphical=true in lightdm.conf zu setzen.
Also in der /etc/lightdm.conf -> entkommentieren der Zeile im Abschnitt [LightDM] #logind-check-graphical=false und Änderung wie folgt von false auf true: logind-check-graphical=true (entkommentieren bedeutet, zudem die Raute # zu entfernen)
Mein Gedanke dahinter: Das tritt nicht immer auf und du hast offenbar zusätzlich eine (Hauppauge?) TV-Karte im System. Eventuell dauert das Initialisieren dieser Karte zu lange. Mit logind-check-graphical=true lässt sich der Check mehr Zeit. Probiere es einfach mal aus.
Ungesicherte Daten sind unwichtige Daten. Niemals einer Befehlszeile vertrauen, ohne zu wissen, was diese bewirkt. Und auch noch das XY-Problem: https://de.wikipedia.org/wiki/XY-Problem

Themen Author
kroschi
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 4
Registriert: Samstag 14. August 2021, 17:25
CPU: Intel Core i3-7300T
GPU: Intel HD Graphics 630
Kernel: 5.10.56-1-MANJARO x86_64
Desktop-Variante: Cinnamon 5.0.5
GPU Treiber: i915
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Re: Problem mit lightdm

#3

Beitrag von kroschi »

Ich habe die Datei entsprechend geändert und es hat geklappt. Jetzt startet der Anmeldebildschirm wieder jedesmal.

Danke Manfrago
Benutzeravatar

Manfrago
Forum Held
Forum Held
Beiträge: 1364
Registriert: Dienstag 8. Dezember 2020, 17:23
Wohnort: Lubeca
CPU: i5 und i7 Gen 3 bis 7
GPU: Intel / Nvidia
Kernel: 5.4 / 5.10
Desktop-Variante: XFCE/Cinnamon
GPU Treiber: Nvidia-390xx / Optimus qt
Hat sich bedankt: 37 Mal
Danksagung erhalten: 241 Mal

Re: Problem mit lightdm

#4

Beitrag von Manfrago »

kroschi hat geschrieben: Sonntag 19. Juni 2022, 15:23 ...und es hat geklappt.
Das hört man gerne. Mich würde persönlich noch interessieren, ob sich am restart counter Wert
lightdm.service: Scheduled restart job, restart counter is at 5.
etwas geändert hat bzw, ob diese Meldung jetzt überhaupt noch erscheint. Mag du mal nachschauen und berichten?
Ungesicherte Daten sind unwichtige Daten. Niemals einer Befehlszeile vertrauen, ohne zu wissen, was diese bewirkt. Und auch noch das XY-Problem: https://de.wikipedia.org/wiki/XY-Problem

Themen Author
kroschi
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 4
Registriert: Samstag 14. August 2021, 17:25
CPU: Intel Core i3-7300T
GPU: Intel HD Graphics 630
Kernel: 5.10.56-1-MANJARO x86_64
Desktop-Variante: Cinnamon 5.0.5
GPU Treiber: i915
Hat sich bedankt: 1 Mal
Danksagung erhalten: 1 Mal

Re: Problem mit lightdm

#5

Beitrag von kroschi »

So hier noch einmal die Meldung:

Code: Alles auswählen

lightdm.service - Light Display Manager
     Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
     Active: active (running) since Sun 2022-06-19 15:30:59 CEST; 2h 6min ago
       Docs: man:lightdm(1)
   Main PID: 437 (lightdm)
      Tasks: 20 (limit: 18929)
     Memory: 177.4M
        CPU: 32.047s
     CGroup: /system.slice/lightdm.service
             ├─437 /usr/bin/lightdm
             └─690 /usr/lib/Xorg :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

Jun 19 15:30:59 frankw systemd[1]: Starting Light Display Manager...
Jun 19 15:30:59 frankw systemd[1]: Started Light Display Manager.
Jun 19 15:31:08 frankw lightdm[824]: pam_unix(lightdm-greeter:session): session opened for user lightdm(uid=966) by (uid=0)
Jun 19 15:31:09 frankw lightdm[890]: pam_systemd_home(lightdm:auth): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
Jun 19 15:31:15 frankw lightdm[890]: gkr-pam: unable to locate daemon control file
Jun 19 15:31:15 frankw lightdm[890]: gkr-pam: stashed password to try later in open session
Jun 19 15:31:15 frankw lightdm[890]: pam_unix(lightdm:session): session opened for user frankw(uid=1000) by (uid=0)
Jun 19 15:31:15 frankw lightdm[890]: pam_env(lightdm:session): deprecated reading of user environment enabled
Jun 19 15:31:15 frankw lightdm[890]: gkr-pam: unlocked login keyring
mit freundlichen Grüßen
kroschi
Benutzeravatar

Manfrago
Forum Held
Forum Held
Beiträge: 1364
Registriert: Dienstag 8. Dezember 2020, 17:23
Wohnort: Lubeca
CPU: i5 und i7 Gen 3 bis 7
GPU: Intel / Nvidia
Kernel: 5.4 / 5.10
Desktop-Variante: XFCE/Cinnamon
GPU Treiber: Nvidia-390xx / Optimus qt
Hat sich bedankt: 37 Mal
Danksagung erhalten: 241 Mal

Re: Problem mit lightdm

#6

Beitrag von Manfrago »

Danke für die Mühe.
Ungesicherte Daten sind unwichtige Daten. Niemals einer Befehlszeile vertrauen, ohne zu wissen, was diese bewirkt. Und auch noch das XY-Problem: https://de.wikipedia.org/wiki/XY-Problem
Antworten

Zurück zu „Manjaro Cinnamon Edition“