Fehlermeldungen beim Hochfahren

Probleme und Fragen zur Open RC Variante ist hier das Thema!
Antworten
Benutzeravatar

Themen Author
drelanger
Forum Kenner
Forum Kenner
Beiträge: 196
Registriert: Mittwoch 18. Mai 2016, 09:54
GPU:
Kernel:
DE:
GPU Treiber:

Fehlermeldungen beim Hochfahren

#1

#1 Beitrag von drelanger » Dienstag 10. Januar 2017, 21:28

Moin zusammen,

beim Hochfahren des Desktop-PC's erhalte ich 4 Fehlermeldungen:
Failed to load vboxdrv, vboxnetadp, vboxnetflt, vboxpci.

Das hängt sicherlich mit der Virtualbox zusammen, die ich zwar neben anderer Software installiert aber noch nicht in Betrieb genommen habe.

Was ist da zu tun? Auf dem Notebook habe ich Virtualbox und wollte die Software am PC intensiver nutzen.
Erfolg ist die Summe vermiedener, kleiner Fehler.

Benutzeravatar

Josef_K
Forum Kenner
Forum Kenner
Beiträge: 178
Registriert: Mittwoch 18. Mai 2016, 16:08
CPU: i5-4460
GPU: GeForce GT 730
Kernel: 4.20
DE: XFCE
GPU Treiber: nvidia v: 410.78
Danksagung erhalten: 9 Mal

Re: Fehlermeldungen beim Hochfahren

#2

#2 Beitrag von Josef_K » Mittwoch 11. Januar 2017, 09:29

Hallo Drelanger,

dir fehlt wahrscheinlich

Code: Alles auswählen

sudo pacman -S virtualbox virtualbox-dkms-manjaro linux48-virtualbox-host-modules
falls dein Profil noch stimmt, sonst musst du die linux48-virtualbox-host-modules anpassen, z.b

Code: Alles auswählen

linux49-virtualbox-host-modules
für den Kernel 4.9.

http://www.manjaro-forum.de/index.php/t ... ml#msg3421

Grüße
Josef
Zuletzt geändert von Josef_K am Mittwoch 11. Januar 2017, 09:37, insgesamt 1-mal geändert.
PGV ecogold, HP Pavilion dv7, Raspberry Pi
Manjaro und Void, DE: XFCE

Benutzeravatar

Roberto
Forum Kenner
Forum Kenner
Beiträge: 137
Registriert: Freitag 20. Mai 2016, 19:20
Wohnort: Kölle am Ring
CPU: Intel Core i5 M 540
GPU: Intel Core Processor Integrated Graphics
Kernel: 4.20.6-artix1-1-ARTIX x86_64
DE: KDE Plasma 5.14.5
GPU Treiber: i915

Re: Fehlermeldungen beim Hochfahren

#3

#3 Beitrag von Roberto » Sonntag 19. Februar 2017, 10:17

Hallo Drelanger,

ich hatte das gleiche Problem und habe festgestellt, dass es das Paket virtualbox-dkms-manjaro nicht mehr gibt.

Code: Alles auswählen

[roberto@R510C ~]$ sudo pacman -Ss virtualbox-dkms-manjaro
[roberto@R510C ~]$
[roberto@R510C ~]$ yaourt -Ss virtualbox-dkms-manjaro
[roberto@R510C ~]$
Gruß
Roberto
Lenovo X220 | 128 GB SSD Kingston SV300S3 | 8 GB Ram DDR 3 1333MHz

Benutzeravatar

suska
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 50
Registriert: Mittwoch 18. Mai 2016, 11:58
GPU:
Kernel:
DE:
GPU Treiber:
Danksagung erhalten: 1 Mal

Re: Fehlermeldungen beim Hochfahren

#4

#4 Beitrag von suska » Sonntag 19. Februar 2017, 12:37

Dafür gibts es aber:

virtualbox-guest-dkms
virtualbox-host-dkms

Benutzeravatar

Roberto
Forum Kenner
Forum Kenner
Beiträge: 137
Registriert: Freitag 20. Mai 2016, 19:20
Wohnort: Kölle am Ring
CPU: Intel Core i5 M 540
GPU: Intel Core Processor Integrated Graphics
Kernel: 4.20.6-artix1-1-ARTIX x86_64
DE: KDE Plasma 5.14.5
GPU Treiber: i915

Re: Fehlermeldungen beim Hochfahren

#5

#5 Beitrag von Roberto » Sonntag 19. Februar 2017, 20:02

[quote="suska"]
Dafür gibts es aber:

virtualbox-guest-dkms
virtualbox-host-dkms
[/quote]

Das ist korrekt, ich habe gerade mal kontrolliert und ich habe die beiden Pakete nicht installiert.
Virtualbox läuft trotzdem bei mir einwandfrei.

Wozu dienen diese Pakete?
Lenovo X220 | 128 GB SSD Kingston SV300S3 | 8 GB Ram DDR 3 1333MHz

Benutzeravatar

suska
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 50
Registriert: Mittwoch 18. Mai 2016, 11:58
GPU:
Kernel:
DE:
GPU Treiber:
Danksagung erhalten: 1 Mal

Re: Fehlermeldungen beim Hochfahren

#6

#6 Beitrag von suska » Montag 20. Februar 2017, 15:05

Ich hatte die gleichen Fehlermeldungen wie Drelanger. Nach Installation der beiden Pakete waren sie verschwunden.
Durch die DKMS Pakete werden bei einem Update die nötigen Kernelmodule für den Host automatisch erstellt.

Benutzeravatar

Josef_K
Forum Kenner
Forum Kenner
Beiträge: 178
Registriert: Mittwoch 18. Mai 2016, 16:08
CPU: i5-4460
GPU: GeForce GT 730
Kernel: 4.20
DE: XFCE
GPU Treiber: nvidia v: 410.78
Danksagung erhalten: 9 Mal

Re: Fehlermeldungen beim Hochfahren

#7

#7 Beitrag von Josef_K » Montag 20. Februar 2017, 17:29

[quote="suska"]
Dafür gibts es aber:

virtualbox-guest-dkms
virtualbox-host-dkms
[/quote]


[quote="suska"]
Ich hatte die gleichen Fehlermeldungen wie Drelanger. Nach Installation der beiden Pakete waren sie verschwunden.
Durch die DKMS Pakete werden bei einem Update die nötigen Kernelmodule für den Host automatisch erstellt.
[/quote]


Das Paket virtualbox-guest-dkms braucht nicht extra installiert werden, es wird nur benötigt und automatisch installiert, wenn man Manjaro in der Virtualbox installiert
PGV ecogold, HP Pavilion dv7, Raspberry Pi
Manjaro und Void, DE: XFCE

Benutzeravatar

Roberto
Forum Kenner
Forum Kenner
Beiträge: 137
Registriert: Freitag 20. Mai 2016, 19:20
Wohnort: Kölle am Ring
CPU: Intel Core i5 M 540
GPU: Intel Core Processor Integrated Graphics
Kernel: 4.20.6-artix1-1-ARTIX x86_64
DE: KDE Plasma 5.14.5
GPU Treiber: i915

Re: Fehlermeldungen beim Hochfahren

#8

#8 Beitrag von Roberto » Sonntag 5. März 2017, 14:30

Nun habe ich die beiden angegebenen Pakete nachinstalliert und nun erhalte ich auch nach mehreren Neustarts diese Fehlermeldungen  >:D

Code: Alles auswählen

Mär 05 14:14:58 R510C systemd-modules-load[171]: Failed to insert 'vboxguest': No such device
Mär 05 14:14:58 R510C systemd-modules-load[171]: Failed to insert 'vboxsf': No such device
Mär 05 14:14:58 R510C systemd-modules-load[171]: Failed to insert 'vboxvideo': No such device
Vorher hatte ich diese Fehler nicht.
Lenovo X220 | 128 GB SSD Kingston SV300S3 | 8 GB Ram DDR 3 1333MHz

Benutzeravatar

Josef_K
Forum Kenner
Forum Kenner
Beiträge: 178
Registriert: Mittwoch 18. Mai 2016, 16:08
CPU: i5-4460
GPU: GeForce GT 730
Kernel: 4.20
DE: XFCE
GPU Treiber: nvidia v: 410.78
Danksagung erhalten: 9 Mal

Re: Fehlermeldungen beim Hochfahren

#9

#9 Beitrag von Josef_K » Sonntag 5. März 2017, 16:19

Du brauchst für Virtualbox die Pakete virtualbox-host-dkms und linuxXX-virtualbox-host-modules (XX durch die Kernel-Versionsnummer ohne Punkt ersetzen).


Du solltes in der Gruppe vboxusers sein, ev mit

Code: Alles auswählen

sudo gpasswd <Username> vboxusers
hinzufügen.


Ob die Kernel-Headers benötigt werden, weiss ich jetzt nicht, bei mir sind sie jedenfalls installiert:

Code: Alles auswählen

sudo pacman -S linuxXX-headers

Nach einem

Code: Alles auswählen

sudo modprobe vboxdrv
sollte dann die Virtualbox ohne Neustart von Manjaro funktionieren.


Wiki
Zuletzt geändert von Josef_K am Sonntag 5. März 2017, 16:21, insgesamt 1-mal geändert.
PGV ecogold, HP Pavilion dv7, Raspberry Pi
Manjaro und Void, DE: XFCE

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 892
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.15
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 107 Mal

Re: Fehlermeldungen beim Hochfahren

#10

#10 Beitrag von gosia » Sonntag 5. März 2017, 19:36

Hallo Josef_K,
[quote="Josef_K"]
Du brauchst für Virtualbox die Pakete virtualbox-host-dkms

Du solltes in der Gruppe vboxusers sein
[/quote]
Hm, ich gebe zu, daß ich wenig über Virtualbox weiss, sondern sie einfach nur manchmal benutze. Aber ich habe weder das Paket virtualbox-host-dkms installiert, noch bin ich in der Gruppe vboxuser und es funktioniert trotzdem. Letzteres ist wohl nur notwendig, wenn man USB braucht.

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung...

Benutzeravatar

Roberto
Forum Kenner
Forum Kenner
Beiträge: 137
Registriert: Freitag 20. Mai 2016, 19:20
Wohnort: Kölle am Ring
CPU: Intel Core i5 M 540
GPU: Intel Core Processor Integrated Graphics
Kernel: 4.20.6-artix1-1-ARTIX x86_64
DE: KDE Plasma 5.14.5
GPU Treiber: i915

Re: Fehlermeldungen beim Hochfahren

#11

#11 Beitrag von Roberto » Sonntag 5. März 2017, 20:14

Das habe ich alles bereits gemacht, inkl. einem

Code: Alles auswählen

sudo update-grub
wegen der Kernel Headers.

Hat aber leider alles kein Erfolg gehabt, ich bekomme nach wie vor Fehlermeldungen

Code: Alles auswählen

[roberto@R510C ~]$ systemctl status systemd-modules-load.service
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sun 2017-03-05 20:08:02 CET; 5min ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 180 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 180 (code=exited, status=1/FAILURE)
und im Detail dann zu PID 180:

Code: Alles auswählen

Mär 05 20:08:02 R510C systemd-modules-load[180]: Failed to insert 'vboxguest': No such device
Mär 05 20:08:02 R510C systemd-modules-load[180]: Failed to insert 'vboxsf': No such device
Mär 05 20:08:02 R510C systemd-modules-load[180]: Failed to insert 'vboxvideo': No such device{/code]
Lenovo X220 | 128 GB SSD Kingston SV300S3 | 8 GB Ram DDR 3 1333MHz

Benutzeravatar

Josef_K
Forum Kenner
Forum Kenner
Beiträge: 178
Registriert: Mittwoch 18. Mai 2016, 16:08
CPU: i5-4460
GPU: GeForce GT 730
Kernel: 4.20
DE: XFCE
GPU Treiber: nvidia v: 410.78
Danksagung erhalten: 9 Mal

Re: Fehlermeldungen beim Hochfahren

#12

#12 Beitrag von Josef_K » Sonntag 5. März 2017, 22:37

Hallo Roberto,

du hast anscheinend ein Problem mit Systemd und hier kenne ich mich nicht aus, weil ich OpenRC installiert habe.

@ gosia
[quote="suska"]
Durch die DKMS Pakete werden bei einem Update die nötigen Kernelmodule für den Host automatisch erstellt.
[/quote]
Grüße
Josef
PGV ecogold, HP Pavilion dv7, Raspberry Pi
Manjaro und Void, DE: XFCE

Benutzeravatar

Josef_K
Forum Kenner
Forum Kenner
Beiträge: 178
Registriert: Mittwoch 18. Mai 2016, 16:08
CPU: i5-4460
GPU: GeForce GT 730
Kernel: 4.20
DE: XFCE
GPU Treiber: nvidia v: 410.78
Danksagung erhalten: 9 Mal

Re: Fehlermeldungen beim Hochfahren

#13

#13 Beitrag von Josef_K » Dienstag 7. März 2017, 17:17

Hallo Roberto,

wahrscheinlich hast du Virtualbox auf einem Manjaro-Host installiert. In diesem Fall brauchst du das Paket virtualbox-guest-dkms, welches für die Fehlermeldung verantwortlich ist nicht und es kann entfernt werden.

Dieses Paket wird automatisch mitinstalliert, wenn Manjaro in einer Virtualbox  installiert wird.

Poste mal die Ausgabe von

Code: Alles auswählen

pacman -Qs virtualbox
Bei mir sieht das für die Kernel 4.4 und 4.9 so aus:

Code: Alles auswählen

pacman -Qs virtualbox
local/linux44-virtualbox-host-modules 5.1.14-5 (linux44-extramodules)
    Host kernel modules for VirtualBox
local/linux49-virtualbox-host-modules 5.1.14-7 (linux49-extramodules)
    Host kernel modules for VirtualBox
local/virtualbox 5.1.14-3
    Powerful x86 virtualization for enterprise as well as home use
local/virtualbox-host-dkms 5.1.14-3
    VirtualBox Host kernel modules sources
bbs.archlinux.org/viewtopic.php?id=210194

Grüße
Josef
Zuletzt geändert von Josef_K am Dienstag 7. März 2017, 17:21, insgesamt 1-mal geändert.
PGV ecogold, HP Pavilion dv7, Raspberry Pi
Manjaro und Void, DE: XFCE

Benutzeravatar

Roberto
Forum Kenner
Forum Kenner
Beiträge: 137
Registriert: Freitag 20. Mai 2016, 19:20
Wohnort: Kölle am Ring
CPU: Intel Core i5 M 540
GPU: Intel Core Processor Integrated Graphics
Kernel: 4.20.6-artix1-1-ARTIX x86_64
DE: KDE Plasma 5.14.5
GPU Treiber: i915

Re: Fehlermeldungen beim Hochfahren

#14

#14 Beitrag von Roberto » Dienstag 7. März 2017, 21:06

Hallo Josef,

du hast es auf den Punkt gebracht, das war genau mein Problem.
Nachdem ich das Paket virtualbox-guest-dkms deinstalliert habe, waren die Fehlermeldungen weg und das System startet einwandfrei.

VIelen Dank !!  ;)
Lenovo X220 | 128 GB SSD Kingston SV300S3 | 8 GB Ram DDR 3 1333MHz

Antworten