OBS-Studio kein Nvenc

Die Manjaro Gnome Edition ist hier die Diskussionsplattform
Antworten
Benutzeravatar

Themen Author
Lucius
Forum Kenner
Forum Kenner
Beiträge: 120
Registriert: Donnerstag 20. Dezember 2018, 22:11
Wohnort: Düsseldorf
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: 5.10.23-1-MANJARO
Desktop-Variante: GNOME 3.38.4
GPU Treiber: Nvidia Driver 460.56
Hat sich bedankt: 13 Mal
Danksagung erhalten: 3 Mal

OBS-Studio kein Nvenc

#1

Beitrag von Lucius »

Hallo, ich habe mal wieder ein kleines Problem mit OBS :) Und zwar möchte irgendwie das Nvenc über diese OBS Version: https://snapcraft.io/obs-studio nicht so. Ich bekomme bei versuch eine Aufnahme zu machen diesen Fehler:

Bild
Bild

Grafikkartentreiber ist Installiert.

Code: Alles auswählen

ffmpeg -codecs | grep nvenc                                                                                                                                                  ABRT ✘  6s  
ffmpeg version n4.3.2 Copyright (c) 2000-2021 the FFmpeg developers
  built with gcc 10.2.0 (GCC)
  configuration: --prefix=/usr --disable-debug --disable-static --disable-stripping --enable-amf --enable-avisynth --enable-cuda-llvm --enable-lto --enable-fontconfig --enable-gmp --enable-gnutls --enable-gpl --enable-ladspa --enable-libaom --enable-libass --enable-libbluray --enable-libdav1d --enable-libdrm --enable-libfreetype --enable-libfribidi --enable-libgsm --enable-libiec61883 --enable-libjack --enable-libmfx --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librav1e --enable-libsoxr --enable-libspeex --enable-libsrt --enable-libssh --enable-libtheora --enable-libv4l2 --enable-libvidstab --enable-libvmaf --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxcb --enable-libxml2 --enable-libxvid --enable-libzimg --enable-nvdec --enable-nvenc --enable-shared --enable-version3
  libavutil      56. 51.100 / 56. 51.100
  libavcodec     58. 91.100 / 58. 91.100
  libavformat    58. 45.100 / 58. 45.100
  libavdevice    58. 10.100 / 58. 10.100
  libavfilter     7. 85.100 /  7. 85.100
  libswscale      5.  7.100 /  5.  7.100
  libswresample   3.  7.100 /  3.  7.100
  libpostproc    55.  7.100 / 55.  7.100
 DEV.LS h264                 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 (decoders: h264 h264_v4l2m2m h264_qsv h264_cuvid ) (encoders: libx264 libx264rgb h264_amf h264_nvenc h264_qsv h264_v4l2m2m h264_vaapi nvenc nvenc_h264 )
 DEV.L. hevc                 H.265 / HEVC (High Efficiency Video Coding) (decoders: hevc hevc_qsv hevc_v4l2m2m hevc_cuvid ) (encoders: libx265 nvenc_hevc hevc_amf hevc_nvenc hevc_qsv hevc_v4l2m2m hevc_vaapi )
Liebe Grüße
Lucius
Benutzeravatar

zompel
Forum Kenner
Forum Kenner
Beiträge: 197
Registriert: Montag 9. Dezember 2019, 19:52
Wohnort: Essen, NRW
CPU: Intel Core i9-9900KF
GPU: nVidia GeForce RTX 2070
Kernel: Linux 5.10 LTS
Desktop-Variante: Gnome 3.38
GPU Treiber: nVidia
Hat sich bedankt: 5 Mal
Danksagung erhalten: 40 Mal

Re: OBS-Studio kein Nvenc

#2

Beitrag von zompel »

Schon mal obs-studio aus den Manjaro Repos probiert?
Benutzeravatar

Themen Author
Lucius
Forum Kenner
Forum Kenner
Beiträge: 120
Registriert: Donnerstag 20. Dezember 2018, 22:11
Wohnort: Düsseldorf
CPU: Intel Core i7-7820X
GPU: GeForce GTX 1080 Ti
Kernel: 5.10.23-1-MANJARO
Desktop-Variante: GNOME 3.38.4
GPU Treiber: Nvidia Driver 460.56
Hat sich bedankt: 13 Mal
Danksagung erhalten: 3 Mal

Re: OBS-Studio kein Nvenc

#3

Beitrag von Lucius »

Hi, ja hab ich, das Problem ist soweit gelöst, weil ich ein Zusätzlichen OBS aus den Offiziellen Repository installiert habe.
Jetzt funktionieren beide ohne Problem :)
Liebe Grüße
Lucius
Antworten