X.org(xserver) defekt

Linux Mint, Ubuntu, elementary und Co. Hier kann über andere Linux Distributionen Diskutiert werden.
Antworten

Themen Author
Popelmaniac
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 62
Registriert: Samstag 1. Dezember 2018, 07:21
CPU: AMD Ryzen 5 2400 G
GPU: HD
Kernel: 5.x
Desktop-Variante: DE
GPU Treiber: radeon
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

X.org(xserver) defekt

#1

Beitrag von Popelmaniac »

Mein Archlinux startet nicht mehr. Ich habe xserver kein Wayland.

Als Fehlermeldung bekomme ich während des bootens:

Code: Alles auswählen

xf86EnableIOPorts:failed to set IOPL for I/O (Operation not permitted) 
Fatal server error
Was kann ich machen um den Fehler zu beseitigen?

Themen Author
Popelmaniac
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 62
Registriert: Samstag 1. Dezember 2018, 07:21
CPU: AMD Ryzen 5 2400 G
GPU: HD
Kernel: 5.x
Desktop-Variante: DE
GPU Treiber: radeon
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: X.org(xserver) defekt

#2

Beitrag von Popelmaniac »

Hallo wie macht man vom X.org oder xserver ein Downgrade?

Themen Author
Popelmaniac
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 62
Registriert: Samstag 1. Dezember 2018, 07:21
CPU: AMD Ryzen 5 2400 G
GPU: HD
Kernel: 5.x
Desktop-Variante: DE
GPU Treiber: radeon
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: X.org(xserver) defekt

#3

Beitrag von Popelmaniac »

Ich bräuchte ein Script zum Downgrade von X.org oder xserver? Wer kann es mir hier posten?
Benutzeravatar

djeli
Forum Held
Forum Held
Beiträge: 669
Registriert: Samstag 21. Mai 2016, 12:12
GPU:
Kernel:
Desktop-Variante:
GPU Treiber:
Hat sich bedankt: 32 Mal
Danksagung erhalten: 71 Mal

Re: X.org(xserver) defekt

#4

Beitrag von djeli »


Themen Author
Popelmaniac
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 62
Registriert: Samstag 1. Dezember 2018, 07:21
CPU: AMD Ryzen 5 2400 G
GPU: HD
Kernel: 5.x
Desktop-Variante: DE
GPU Treiber: radeon
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: X.org(xserver) defekt

#5

Beitrag von Popelmaniac »

@djeli
Danke.
Ich bekamm downgrade im Terminal ohne gui installiert.
Ich habe dann xorg-server mit pacman installiert.
Wenn ich startx im Terminal eingebe bekomme ich

Code: Alles auswählen

startx
xauth:timeout in locking authority file ~/.Xauthority
Was kann ich da machen? Welche Eingaben sind Notwendig?

Themen Author
Popelmaniac
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 62
Registriert: Samstag 1. Dezember 2018, 07:21
CPU: AMD Ryzen 5 2400 G
GPU: HD
Kernel: 5.x
Desktop-Variante: DE
GPU Treiber: radeon
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: X.org(xserver) defekt

#6

Beitrag von Popelmaniac »

Hier ein Auschnitt der xorg.0.log

Code: Alles auswählen

[   123.592] (WW) xf86CloseConsole: KDSETMODE failed: Input/output error
[   123.592] (WW) xf86CloseConsole: VT_GETMODE failed: Input/output error
[   123.592] (WW) xf86CloseConsole: VT_ACTIVATE failed: Input/output error
[   123.592] (EE) systemd-logind: ReleaseControl failed: Connection is closed
[   123.592] (II) Server terminated successfully (0). Closing log file.

Themen Author
Popelmaniac
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 62
Registriert: Samstag 1. Dezember 2018, 07:21
CPU: AMD Ryzen 5 2400 G
GPU: HD
Kernel: 5.x
Desktop-Variante: DE
GPU Treiber: radeon
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: X.org(xserver) defekt

#7

Beitrag von Popelmaniac »

Ich habe Archlinux Plattgemacht, damit gelöst.
Ich danke an alle die mir Helfen wollten.

Themen Author
Popelmaniac
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 62
Registriert: Samstag 1. Dezember 2018, 07:21
CPU: AMD Ryzen 5 2400 G
GPU: HD
Kernel: 5.x
Desktop-Variante: DE
GPU Treiber: radeon
Hat sich bedankt: 2 Mal
Danksagung erhalten: 1 Mal

Re: X.org(xserver) defekt

#8

Beitrag von Popelmaniac »

Das Problem mit Arch hat sich erledigt da ich Arch Plattgemacht habe.
Antworten