Fragen oder Probleme zu Linux Kernel bitte hier rein!

Probleme bei der Installation von Hardware unter Manjaro Linux? Hier wird geholfen.</span
Benutzeravatar

Themen Author
manjarofan
Forum Held
Forum Held
Beiträge: 849
Registriert: Di 24. Nov 2015, 08:43
Wohnort: Zittau
CPU: Intel® Core™ i7-2630QM
GPU: Nvidia Geforce GT 650M
Kernel: 4,19
DE: Manjaro 18 Mate
GPU Treiber: Free
Hat sich bedankt: 20 Mal
Danksagung erhalten: 21 Mal
Kontaktdaten:

Fragen oder Probleme zu Linux Kernel bitte hier rein!

#1

#1 Beitrag von manjarofan » Fr 27. Mai 2016, 10:50

Wenn mal nach dem Update mit neuen Linux Kernel das Manjaro System spinnt oder gar nicht mehr anlaufen will, dann bitte diesen Thread nutzen. Danke.
OS: Manjaro 18.0. Illyria, Kernel: x86_64 Linux 4.19.....-MANJARO DE: MATE Theme: Vertex-Maia, Icon Theme: Vertex-Maia,  CPU: Intel Core i5-3210M CPU @ 3.1GHz, GPU: Mesa DRI Intel(R) Ivybridge Mobil

Benutzeravatar

drelanger
Forum Kenner
Forum Kenner
Beiträge: 196
Registriert: Mi 18. Mai 2016, 09:54
GPU:
Kernel:
DE:
GPU Treiber:

Graphische Oberfläche sartet nicht mehr

#2

#2 Beitrag von drelanger » Mi 18. Jan 2017, 07:10

Moin zusammen.

Ich schreib das mal hier rein, weil ich gestern erfolglos versucht habe, das Update zu installieren. Die erforderlichen Schritte zur Aktualisierung  wie keyrings, synchronisieren etc. habe ich bereits ausgeführt.
Heute Morgen startete mein Notebook nicht mehr mit der Mitteilung, dass:

Failed to start load Kernel modules

Der X_Server konnte nicht gestartet werden!

Benutzt wurde bis dahin der Kernel: 4.4.41.-1

Ich habe dann den Kernel 4.1.37.-1 ausgewählt, woraufhin das Notebook wieder mit graphischer Oberfläche startete und damit wieder einsatzfähig wurde.

Also zwei Probleme: Ich kann das Update nicht aufspielen und womöglich wegen der ausgeführten Maßnahmen
habe ich mit dem neueren Kernel keine graphische Oberfläche mehr.
Erfolg ist die Summe vermiedener, kleiner Fehler.

Benutzeravatar

drelanger
Forum Kenner
Forum Kenner
Beiträge: 196
Registriert: Mi 18. Mai 2016, 09:54
GPU:
Kernel:
DE:
GPU Treiber:

Re: Fragen oder Probleme zu Linux Kernel bitte hier rein!

#3

#3 Beitrag von drelanger » Mi 18. Jan 2017, 07:51

Mit dem älteren Kernel ist jetzt auch das Update völlig problemlos zu installieren gewesen.

Ich vermute, das dieser Kernel noch für allerlei anderen Spuk auf diesem Notebook verantwortlich war, aber das wird sich erst im Laufe der Zeit erweisen.

Einen zweiten Kernel starten zu können, hat sich als sehr segensreich erwiesen und ich möchte den defekten Kernel löschen. Es stehen zwei neuere Kernel zur Verfügung, welchen von beiden sollte ich nehmen?
Erfolg ist die Summe vermiedener, kleiner Fehler.

Benutzeravatar

Blueriver
Moderator
Moderator
Beiträge: 1650
Registriert: Do 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 4.19
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Danksagung erhalten: 5 Mal

Re: Fragen oder Probleme zu Linux Kernel bitte hier rein!

#4

#4 Beitrag von Blueriver » Mi 18. Jan 2017, 08:03

Ich würde den 4.9 nehmen, der wird wahrscheinlich LTS werden.
Manjaro LXQT und XFCE Stable, Testing, Unstable
CPU: AMD Quad Core A8 3,6GHz
Graka: AMD/ATI Radeon R7
Treiber: Free
Kernel: 4.19


Amber

Re: Fragen oder Probleme zu Linux Kernel bitte hier rein!

#5

#5 Beitrag von Amber » Mi 18. Jan 2017, 09:29

[quote="Blueriver"]
Ich würde den 4.9 nehmen, der wird wahrscheinlich LTS werden.
[/quote]

Wo hast Du die Information her, laut Hartmann ist es noch nicht festgelegt?

I reserve the right to not pick 4.9 and support it for two years, if it’s a major pain because people abused this notice. If so, I’ll possibly drop back to 4.8, or just wait for 4.10 to be released. I’ll let everyone know by updating the kernel.org releases page when it’s time (many months from now.

auf Seite http://kroah.com/log/blog/2016/09/06/4- ... ts-kernel/

Benutzeravatar

Blueriver
Moderator
Moderator
Beiträge: 1650
Registriert: Do 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 4.19
DE: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Danksagung erhalten: 5 Mal

Re: Fragen oder Probleme zu Linux Kernel bitte hier rein!

#6

#6 Beitrag von Blueriver » Mi 18. Jan 2017, 09:46

Ist ja nicht sicher LTS, deshalb habe ich ja wahrscheinlich geschrieben.

Aber der 4.8 ist schon EOL und deshalb würde ich den 4.9 nehmen.
Manjaro LXQT und XFCE Stable, Testing, Unstable
CPU: AMD Quad Core A8 3,6GHz
Graka: AMD/ATI Radeon R7
Treiber: Free
Kernel: 4.19

Benutzeravatar

drelanger
Forum Kenner
Forum Kenner
Beiträge: 196
Registriert: Mi 18. Mai 2016, 09:54
GPU:
Kernel:
DE:
GPU Treiber:

Re: Fragen oder Probleme zu Linux Kernel bitte hier rein!

#7

#7 Beitrag von drelanger » Mi 18. Jan 2017, 13:21

Leider startet der 4.9. Kernel auch nicht den Xserver.
Erfolg ist die Summe vermiedener, kleiner Fehler.

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 612
Registriert: Di 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.15
DE: Openbox
GPU Treiber: i915
Danksagung erhalten: 1 Mal

Re: Graphische Oberfläche sartet nicht mehr

#8

#8 Beitrag von gosia » Mi 18. Jan 2017, 13:39

Hallo Ecki,
drelanger hat geschrieben: Failed to start load Kernel modules
Poste mal bitte mit dem Kernel, bei dem die Fehlermeldung mit den Modulen kam, die Ausgabe von

Code: Alles auswählen

sudo systemctl status systemd-modules-load.service
Viele Grüße gosia

PS. Und dein Profil war auch mal ausgefüllter, oder?

PS.PS. Ich hatte vorher "4.9-Kernel" geschrieben, bin jetzt aber nicht mehr sicher, welchen Kernel Du gerade versucht hast, upzudaten.
Zuletzt geändert von gosia am Mi 18. Jan 2017, 13:46, insgesamt 1-mal geändert.
"funktioniert nicht" ist keine brauchbare Fehlermeldung...

Benutzeravatar

drelanger
Forum Kenner
Forum Kenner
Beiträge: 196
Registriert: Mi 18. Mai 2016, 09:54
GPU:
Kernel:
DE:
GPU Treiber:

Re: Fragen oder Probleme zu Linux Kernel bitte hier rein!

#9

#9 Beitrag von drelanger » Mi 18. Jan 2017, 14:50

Moin Gosia,

den Moment habe ich den 4.9.2-1 Installiert, zuvor war es der 4.9. rtl Echtzeit.

Mit dem alten Kernel kam ich gar nicht bis zur Eingabeaufforderung, also auch kein Terminal. Im übrigen habe ich den bereits runter geschmissen.

Was seltsam ist: Ich hatte den 4.9. rtl installiert, während des Starts bei der Wahl des Kernels /erweiterte Optionen, hatte ich den 4.9. rtl gewählt, woraufhin auch kein Xserver startete. Jetzt stellte ich fest, dass bei Manjaro Einstellungen Kernel der 4.9. rtl gar nicht als installiert geführt wurde. Also habe ich ihn nochmal installiert, da bekomme ich die Meldung, dass er reinstalliert wird. also habe ich das gewähren lassen und nach Reinstallation die Deinstallation durchgeführt um den
4.9.2-1 stattdessen zu installieren. Den habe ich bisher nicht getestet
Erfolg ist die Summe vermiedener, kleiner Fehler.

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 612
Registriert: Di 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.15
DE: Openbox
GPU Treiber: i915
Danksagung erhalten: 1 Mal

Re: Fragen oder Probleme zu Linux Kernel bitte hier rein!

#10

#10 Beitrag von gosia » Mi 18. Jan 2017, 16:57

Hallo Ecki,
ich bin etwas verwirrt. Wie ist der Stand der Dinge? Da ich früher immer "Was bin ich?" gesehen habe, fange ich mal so an:
"Gehe ich recht in der Annahme, dass..." Du jetzt Kernel 4.9.2-1 installiert aber noch nicht getestet, das heisst, noch nicht gestartet hast? (Bei der Gelegenheit, Kernel 4.9_rt1-1 brauchst Du sehr wahrscheinlich nicht).
Aber wenn noch nicht getestet, wie sollen wir dann diese Fehlermeldung verstehen?
drelanger hat geschrieben: Leider startet der 4.9. Kernel auch nicht den Xserver.

Den alten Kernel mit der Fehlermeldung

Code: Alles auswählen

Failed to start load Kernel modules
hast Du schon wieder entfernt?
Der Kern meiner Verwirrung steckt dann hier:
drelanger hat geschrieben: Benutzt wurde bis dahin der Kernel: 4.4.41.-1
Ich habe dann den Kernel 4.1.37.-1 ausgewählt, woraufhin das Notebook wieder mit graphischer Oberfläche startete und damit wieder einsatzfähig wurde.
Also zwei Probleme: Ich kann das Update nicht aufspielen und womöglich wegen der ausgeführten Maßnahmen
habe ich mit dem neueren Kernel keine graphische Oberfläche mehr.
Welcher Kernel ist nun regulär in Benutzung 4.1.37.-1, 4.4.41.-1 und/oder 4.9.2-1 bzw. soll benutzt werden?
Und welche Fehlermeldung wartet auf die Behandlung?
  1. Update nicht möglich
  2. Failed to start load Kernel modules
  3. keine graphische Oberfläche mehr
wobei Fehler 3. durchaus aus Fehler 2. resultieren kann, oder anders ausgedrückt: Es ist gut möglich, daß mit der Beseitigung von Fehler 2. auch Fehler 3. verschwindet.

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung...

Benutzeravatar

drelanger
Forum Kenner
Forum Kenner
Beiträge: 196
Registriert: Mi 18. Mai 2016, 09:54
GPU:
Kernel:
DE:
GPU Treiber:

Re: Fragen oder Probleme zu Linux Kernel bitte hier rein!

#11

#11 Beitrag von drelanger » Mi 18. Jan 2017, 17:20

Installiert waren:

4-1-37-1 und  4.4.41.-1 letzterer wurde auch genutzt brachte aber den Xserver nicht mehr auf die Beine.

Wechsel zu 4-1-37-1 mit dem ich im Moment noch unterwegs bin und funktioniert.

Installation von 4.9_rt1-1 und Löschung von 4.4.41.-1.

Da 4.9_rt1-1 ebenfalls keine graph. Oberfläche zustande brachte, Löschung desselben und Installation von  4.9.2-1, den ich aber noch nicht ausprobiert habe. Komme ich erst später dazu
Erfolg ist die Summe vermiedener, kleiner Fehler.


Amber

Re: Fragen oder Probleme zu Linux Kernel bitte hier rein!

#12

#12 Beitrag von Amber » Mi 18. Jan 2017, 20:28

[quote="drelanger"]
Leider startet der 4.9. Kernel auch nicht den Xserver.
[/quote]
Warum sollte er das auch tun??

Benutzeravatar

drelanger
Forum Kenner
Forum Kenner
Beiträge: 196
Registriert: Mi 18. Mai 2016, 09:54
GPU:
Kernel:
DE:
GPU Treiber:

Re: Fragen oder Probleme zu Linux Kernel bitte hier rein!

#13

#13 Beitrag von drelanger » Mi 18. Jan 2017, 20:58

Der Kernel 4.9.2-1 startet mit graph. Oberfläche, aber bereits beim Hochfahren erscheint die Meldung:

ACPI watchdog failed to create platform devices.

Ich habe seit längerer  Zeit und zwar nicht nur wegen dieser Fehlermeldung den dringenden Verdacht, dass mit meiner acpi etwas nicht in Ordnung sein kann, denn das Problem mit dem Watchdog bspw. ist nicht neu
Erfolg ist die Summe vermiedener, kleiner Fehler.

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 612
Registriert: Di 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.15
DE: Openbox
GPU Treiber: i915
Danksagung erhalten: 1 Mal

Re: Fragen oder Probleme zu Linux Kernel bitte hier rein!

#14

#14 Beitrag von gosia » Mi 18. Jan 2017, 22:44

Hallo Ecki,
wahrscheinlich bin ich heute besonders dusslig, aber irgendwie habe ich den Eindruck, daß die Probleme fast stündlich wechseln...
[quote="drelanger"]
Der Kernel 4.9.2-1 startet mit graph. Oberfläche, aber bereits beim Hochfahren erscheint die Meldung:
ACPI watchdog failed to create platform devices.
[/quote]
Ich verstehe das jetzt so, daß Du mit Kernel 4.9.2-1 normal in der grafischen Oberfläche arbeiten kannst, nur unterwegs beim Hochfahren erscheint unterwegs die Fehlemeldung mit "ACPI watchdog..."
Bei dem Fehler muss ich leider das Handtuch werfen, keine Ahnung von ACPI

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung...


Amber

Re: Fragen oder Probleme zu Linux Kernel bitte hier rein!

#15

#15 Beitrag von Amber » Do 19. Jan 2017, 09:16

Moin,

damit man eine klare Linie bekommt sei geschrieben das der kernel keine grafische Oberfläche hat ergo kann das Problem nicht am kernel liegen sondern evtl Treiber.

Watchdog Dienst ist gestartet?

Code: Alles auswählen

sudo pacman -S watchdog
sudo systemctl enable watchdog.service
sudo systemctl start watchdog.service

Antworten