(KDE-)GUI friert beim Booten ein

Support rund um die Manjaro KDE Edition findet man in dieser Kategorie!
Antworten

Themen Author
An_Arch_It
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 5
Registriert: Montag 11. Januar 2021, 18:28
CPU: AMD Athlon X4 840 Quad Processor
GPU: GeForce GTX 750 Ti (NV117)
Kernel: 5.4.89-1 LTS
Desktop-Variante: KDE-Plasma
GPU Treiber: nvidia 390xx

(KDE-)GUI friert beim Booten ein

#1

Beitrag von An_Arch_It »

Liebe Community,
ich habe seit heute ein sehr gravierendes Problem mit meinem Manjaro. Wie der Titel schon sagt friert nur die GUI ein. Ich habe eigentlich nur eine einzige Einstellung gemacht, welche dazu führte, was die Fehlersuche natürlich vereinfacht. Ich habe so ein Drehmonitor, den man 90° auf die Seite kippen kann, verwende ich immer zum Flippern, sonst kein Problem heute aber schon. Ich geh also in die Grafikeinstellung, da wo man auch die Auflösung für den Arbeitsplatz einstellt und klickte auf die Kipp-Funktion. Es klappte nicht wie sonst, ich weiß nicht mehr genau was war, ich glaube das Bild war irgendwie abgeschnitten oder so, machte also einen Kaltstart, der mich aus Freezes eigentlich immer befreit. In dem Fall bekomme ich den Ladebildschirm von Manjaro, nachdem ich Manjaro im Grub ausgewählt habe wie immer, aber dann kippt das Bild (des Ladebildschirms) so zur Seite und wird abgeschnitten und das bleibt dann so (Mauszeiger kann man bewegen), habe bestimmt 10 Neustarts oder so gemacht immer das gleiche. Nun muss ich dazu sagen, dass ich gestern schonmal einen Absturz bei Euro Truck Simulator 2 hatte und seitdem zeigte mir mein Compositor so eine Meldung an(siehe Bild). Ich klickte aber nicht auf "OpenGL-Erkennung wieder aktivieren" und danach trat dieses unerklärliche merkwürdige Phenomen auf.
Ich weiß z.B., dass das System hinter diesem "Freeze" läuft, weil ich habe ein Terminal aufgerufen und mit "shutdown -r now" einen Neustart machen können. Ausserdem habe mit Alt+Strg+F2 auf die nicht-grafische-Oberfläche von Manjaro. Das System (Manjaro 20.2.1 Nibia) war gestern auch/heute auch noch ganz up to date, also daran liegts nicht. Als Grafiktreiber benutze ich den nvidia390 und als Kernel den 5.4.89-1 LTS)
Das aber am aller beunruhigendsten an der Sache ist. Ich habe mit Timeshift ein Snapshot von gestern wiederhergestellt (home-Verzeichnis wird bei mir ausgenommen) und es hat nichts gebracht. Das Problem muss sich also in meinem home-Verzeichnis befinden. Dann habe ich auch mal "kwin-wayland --replace" eingetippt und der Rechner hat bestimmt eine Minute gerödelt, aber sonst keine Änderung. Auch "killall plasmashell" in Verbindung mit "kstart5 plasmashell" hat nichts gebracht und nun bin ich mit meinem Latein langsam am Ende, was könnte man da machen ??
Dateianhänge
3530.png
3530.png (108.87 KiB) 1581 mal betrachtet
Benutzeravatar

zompel
Forum Kenner
Forum Kenner
Beiträge: 198
Registriert: Montag 9. Dezember 2019, 19:52
Wohnort: Essen, NRW
CPU: Intel Core i9-9900KF
GPU: nVidia GeForce RTX 2070
Kernel: Linux 5.10 LTS
Desktop-Variante: Gnome 3.38
GPU Treiber: nVidia
Hat sich bedankt: 5 Mal
Danksagung erhalten: 40 Mal

Re: (KDE-)GUI friert beim Booten ein

#2

Beitrag von zompel »

Weiß zwar nicht wie man es beheben könnte, aber solange du noch keinen anderen Hinweis bekommst würde ich mich als "root" anmelden - woraufhin ja wieder alles normal laufen sollte - und anschließend versuchsweise ein paar versteckte Ordner im Benutzer home Verzeichnis umbenennen (nicht löschen) und schauen ob sich der Fehler eingrenzen lässt.
Notfalls kann man die umbenannten Ordner wiederherstellen.

edit:

Wobei ich jetzt nicht sicher bin ob sich die Rechte der Ordner ändern und du als Benutzer nacher Probleme bekommst...
dachte nur dass du als root vielleicht leichter arbeiten könntest, wenn die Bildschirmeinstellungen wieder normal sind.
Ansonsten kannst du natürlich auch als Benutzer die versteckten Ordner umbenennen.

Themen Author
An_Arch_It
Neues Foren Mitglied
Neues Foren Mitglied
Beiträge: 5
Registriert: Montag 11. Januar 2021, 18:28
CPU: AMD Athlon X4 840 Quad Processor
GPU: GeForce GTX 750 Ti (NV117)
Kernel: 5.4.89-1 LTS
Desktop-Variante: KDE-Plasma
GPU Treiber: nvidia 390xx

Re: (KDE-)GUI friert beim Booten ein

#3

Beitrag von An_Arch_It »

Hey zompel,
zompel hat geschrieben: Dienstag 2. März 2021, 08:46 versuchsweise ein paar versteckte Ordner im Benutzer home Verzeichnis umbenennen (nicht löschen) und schauen ob sich der Fehler eingrenzen lässt.
Die Idee ist gut. War zwar Arbeit erstmal eine Liste der Verdächtigen zu erstellen, aber ich habe mir erstmal eine Liste erstellt mit allen Dateien und Ordnern, welche sich seit dem Tag des Unfalls (28. Februar) oder später geändert haben. Dann habe ich glücklicherweise mit dem richtigen Verzeichnis angefangen und immer 5 Dateien/Ordner umbenannt, das System neu gebootet und geprüft obs bessser ist. Bereits bei den zweiten Fünf war der Fehler komplett weg und der Desktop wurde wieder normal angezeigt. Der Schuldige war die Datei kwinrc in meinem versteckten config-Ordner. Linux erstellte beim Booten eine neue stark verkürzte kwinrc selbst und die tat es dann. Meine war schon völlig aufgebläht über die Monate und ich wusste nicht einmal was die damaligen Standardeinstellungen waren.

Übrigens : die Rechte haben sich durch das Umbenennen nicht geändert soweit ich das feststellen konnte.

Ich bin jedenfalls froh, dass ich in dem Fall die Lösung schon gleichen Tag finden konnte. Ein bißchen Glück war sicherlich auch dabei, aber bedanke mich nochmal für die Idee. :)
Benutzeravatar

zompel
Forum Kenner
Forum Kenner
Beiträge: 198
Registriert: Montag 9. Dezember 2019, 19:52
Wohnort: Essen, NRW
CPU: Intel Core i9-9900KF
GPU: nVidia GeForce RTX 2070
Kernel: Linux 5.10 LTS
Desktop-Variante: Gnome 3.38
GPU Treiber: nVidia
Hat sich bedankt: 5 Mal
Danksagung erhalten: 40 Mal

Re: (KDE-)GUI friert beim Booten ein

#4

Beitrag von zompel »

Freut mich...Super!! :)
Antworten