WIederkehrender Fehler beim booten

Support rund um die Manjaro KDE Edition findet man in dieser Kategorie!
Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1430
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
Desktop-Variante: Openbox
GPU Treiber: i915
Hat sich bedankt: 7 Mal
Danksagung erhalten: 242 Mal

Re: WIederkehrender Fehler beim booten

#31

Beitrag von gosia »

Hallo DeeBee,
ich kann dir wie gesagt, bei UEFI nicht weiterhelfen. Aber ich weiss soviel, wenn dein Manjaro im UEFI-Modus installiert wurde, solltest Du es auf jeden Fall auch so lassen.
Es gibt immer nur eins, entweder Du benutzt UEFI und dann überall, oder Du benutzt den Legacy-Boot, dann aber auch in allen Betriebssystemen. Eine Mischung von beiden ist tödlich.

viele Grüße gosia

PS. Als Fazit: wenn ich nicht was übersehe, dann ist UEFI schon richtig. Also lass es auch so.
Benutzeravatar

Manfrago
Forum Kenner
Forum Kenner
Beiträge: 107
Registriert: Dienstag 8. Dezember 2020, 17:23
CPU: ausschließlich i7 3.Gen.
GPU: Hybrid
Kernel: 4.19
Desktop-Variante: XFCE
GPU Treiber: Intel/NVIDEA
Hat sich bedankt: 3 Mal
Danksagung erhalten: 7 Mal

Re: WIederkehrender Fehler beim booten

#32

Beitrag von Manfrago »

Ich will mich jetzt nicht zu weit aus dem Fenster lehnen!
Aber: Ich würde auch mal nachschauen wollen, ob bei Windows derzeit gerade ein unvollständiges Update im Hintergrund läuft...
....und auch, ob bei Windows ein Schnellstart da mit reinspielen könnte....
Wenn nicht, ist mein Posting ohnehin Blödsinn und ....bitte weiter nach der Ursache suchen... ;D
Ungesicherte Daten sind unwichtige Daten.

Themen Author
DeeBee
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 54
Registriert: Mittwoch 6. Januar 2021, 20:22
CPU: AMD Rzyen 5 2600
GPU: Amd Rx 580 Sapphire Nitro+
Kernel: 5.9.16-1
Desktop-Variante: KDE Plasma
GPU Treiber: Amdgpu

Re: WIederkehrender Fehler beim booten

#33

Beitrag von DeeBee »

Hallo,
solltest Du es auf jeden Fall auch so lassen.
Okay dann lasse ich es so. Dann ist es ja auch nicht schlimm, wenn es ausgegraut ist.
Ich würde auch mal nachschauen wollen, ob bei Windows derzeit gerade ein unvollständiges Update im Hintergrund läuft...
Das dürfte eigentlich nicht der Fall sein. Erstmal hab ich alle Updates gemacht und da steht auch nichts mehr von update läuft oder so.
und auch, ob bei Windows ein Schnellstart da mit reinspielen könnte
Ich kann ja mal probieren, schnellstart aus zu machen. Müsste ich denn dann Manjaro nochmal neu installieren, damit es funktioniert oder reicht es schon, schnellstart einfach mal aus zu machen?

Viele Grüße DeeBee
Benutzeravatar

Manfrago
Forum Kenner
Forum Kenner
Beiträge: 107
Registriert: Dienstag 8. Dezember 2020, 17:23
CPU: ausschließlich i7 3.Gen.
GPU: Hybrid
Kernel: 4.19
Desktop-Variante: XFCE
GPU Treiber: Intel/NVIDEA
Hat sich bedankt: 3 Mal
Danksagung erhalten: 7 Mal

Re: WIederkehrender Fehler beim booten

#34

Beitrag von Manfrago »

DeeBee hat geschrieben: Montag 11. Januar 2021, 10:36 ...Müsste ich denn dann Manjaro nochmal neu installieren, damit es funktioniert oder reicht es schon, schnellstart einfach mal aus zu machen?
Ne, du brauchst Manjaro nicht neu installieren. Der Schnellstart von Windows verhindert u.a., das ein anderes BS auf gemeinsame genutzte Datenbestände zugreifen kann. Mein Gedanke dazu ist der, das eventuell bei Windows ein Dienst im Hintergrund gestartet wird, welcher möglicherweise den Start eines weiteren BS verhindert. Das kann ich mir zwar eigentlich überhaupt nicht vorstellen - aber deinem Problem kommt man eventuell nur auf die Spur, indem man einige Sachen einfach mal ausprobiert, selbst wenn das nicht unbedingt logisch zu sein scheint. Irgend etwas scheint mir Änderungen an deiner Startpartition vorzunehmen.....nur was?
Ungesicherte Daten sind unwichtige Daten.

Themen Author
DeeBee
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 54
Registriert: Mittwoch 6. Januar 2021, 20:22
CPU: AMD Rzyen 5 2600
GPU: Amd Rx 580 Sapphire Nitro+
Kernel: 5.9.16-1
Desktop-Variante: KDE Plasma
GPU Treiber: Amdgpu

Re: WIederkehrender Fehler beim booten

#35

Beitrag von DeeBee »

Hallo,

Okay ich habe Windows fast boot ausgeschaltet. Danach hat es nur leider immernoch nicht funktioniert. Allerdings habe ich Manjaro dann nochmal neu installiert, woraufhin es natürlich wieder funktioniert hat. Ich war nun extra für ungefähr 2 Stunden in Windows um es zu testen. Und naja bisher läuft manjaro noch super :D . Hoffentlich bleibt es jetzt auch mal so.

Viele Grüße DeeBee
Benutzeravatar

Manfrago
Forum Kenner
Forum Kenner
Beiträge: 107
Registriert: Dienstag 8. Dezember 2020, 17:23
CPU: ausschließlich i7 3.Gen.
GPU: Hybrid
Kernel: 4.19
Desktop-Variante: XFCE
GPU Treiber: Intel/NVIDEA
Hat sich bedankt: 3 Mal
Danksagung erhalten: 7 Mal

Re: WIederkehrender Fehler beim booten

#36

Beitrag von Manfrago »

Lass uns bitte noch mal einen Blick auf deine Partitionierung werfen, solange Manjaro noch läuft...

Code: Alles auswählen

sudo parted -l
Und danach dann bitte dieses Rattenschwanz-Script ausführen, welches uns hoffentlich anzeigt, wo Grub installiert war und ist.

Code: Alles auswählen

sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "dd if=X  bs=1 count=512 2>/dev/null | grep GRUB > /dev/null && echo Grub gefunden: X || echo Kein Grub: X"
Ungesicherte Daten sind unwichtige Daten.

Themen Author
DeeBee
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 54
Registriert: Mittwoch 6. Januar 2021, 20:22
CPU: AMD Rzyen 5 2600
GPU: Amd Rx 580 Sapphire Nitro+
Kernel: 5.9.16-1
Desktop-Variante: KDE Plasma
GPU Treiber: Amdgpu

Re: WIederkehrender Fehler beim booten

#37

Beitrag von DeeBee »

Okay hier sind die Ergebnisse:

Code: Alles auswählen

[juri@juri-ms7a38 ~]$ sudo parted -l
[sudo] Passwort für juri: 
Modell: ATA CT120BX500SSD1 (scsi)
Festplatte  /dev/sda:  120GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt
Disk-Flags: 

Nummer  Anfang  Ende   Größe   Dateisystem     Name  Flags
 1      2097kB  317MB  315MB   fat32                 boot, esp
 2      317MB   102GB  101GB   ext4
 3      102GB   120GB  18,5GB  linux-swap(v1)        swap


Modell: Samsung Flash Drive FIT (scsi)
Festplatte  /dev/sdb:  64,2GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags: 

Nummer  Anfang  Ende    Größe   Typ      Dateisystem  Flags
 2      3226MB  3230MB  4194kB  primary               esp
 3      3231MB  64,2GB  60,9GB  primary  ntfs


Modell: CT1000P1SSD8 (nvme)
Festplatte  /dev/nvme0n1:  1000GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt
Disk-Flags: 

Nummer  Anfang  Ende    Größe   Dateisystem  Name                          Flags
 1      1049kB  524MB   523MB   ntfs         Basic data partition          versteckt, diag
 2      524MB   629MB   105MB   fat32        EFI system partition          boot, esp
 3      629MB   646MB   16,8MB               Microsoft reserved partition  msftres
 4      646MB   1000GB  999GB   ntfs         Basic data partition          msftdata
 5      1000GB  1000GB  579MB   ntfs                                       versteckt, diag


[juri@juri-ms7a38 ~]$ sudo fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sudo sh -c "dd if=X  bs=1 count=512 2>/dev/null | grep GRUB > /dev/null && echo Grub gefunden: X || echo Kein Grub: X"
Kein Grub: /dev/nvme0n1
Kein Grub: /dev/nvme0n1p1
Kein Grub: /dev/nvme0n1p2
Kein Grub: /dev/nvme0n1p3
Kein Grub: /dev/nvme0n1p4
Kein Grub: /dev/nvme0n1p5
Kein Grub: /dev/sda
Kein Grub: /dev/sda1
Kein Grub: /dev/sda2
Kein Grub: /dev/sda3
Grub gefunden: /dev/sdb
Kein Grub: /dev/sdb1
Benutzeravatar

djeli
Forum Held
Forum Held
Beiträge: 583
Registriert: Samstag 21. Mai 2016, 12:12
GPU:
Kernel:
Desktop-Variante:
GPU Treiber:
Hat sich bedankt: 24 Mal
Danksagung erhalten: 58 Mal

Re: WIederkehrender Fehler beim booten

#38

Beitrag von djeli »

Moin
Vieleicht hilft ja dieses Script weiter.
das ergebniss wird im Root Ordner hinterlegt.

https://github.com/arvidjaar/bootinfoscript
Benutzeravatar

Manfrago
Forum Kenner
Forum Kenner
Beiträge: 107
Registriert: Dienstag 8. Dezember 2020, 17:23
CPU: ausschließlich i7 3.Gen.
GPU: Hybrid
Kernel: 4.19
Desktop-Variante: XFCE
GPU Treiber: Intel/NVIDEA
Hat sich bedankt: 3 Mal
Danksagung erhalten: 7 Mal

Re: WIederkehrender Fehler beim booten

#39

Beitrag von Manfrago »

Danke @DeeBee. Kurze Erklärung
Sowie es ausschaut, steckt dein Live Stick noch im PC und dessen Bootsektor wird angezeigt.
Das Script überprüft die ersten 512 Sektoren einer Festplatte auf Hinterlassenschaften eines Grub. Das funktioniert offenbar nicht mit GPT Partitionen, weil die auch ganz anders organisiert sind. Hätte ich mir eigentlich denken können - aber ich habe auch keine praktische Erfahrung mit UEFI. Dennoch fällt mir etwas auf. Deine Festplatten haben jeweils eine eigene EFI Partition - und jetzt müsstest du jemanden mit UEFI Erfahrung fragen, ob das reibungslos so funktioniert, zumal meine Frage wäre, wohin Manjaro eigentlich den Grub gelegt hat.
Ungesicherte Daten sind unwichtige Daten.
Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1430
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
Desktop-Variante: Openbox
GPU Treiber: i915
Hat sich bedankt: 7 Mal
Danksagung erhalten: 242 Mal

Re: WIederkehrender Fehler beim booten

#40

Beitrag von gosia »

Hallo Manfrago,
Manfrago hat geschrieben: Montag 11. Januar 2021, 20:34 Deine Festplatten haben jeweils eine eigene EFI Partition
ja, das ist IMHO zuviel, dürfte aber eigentlich nicht stören. Der Bootloader schnappt sich wohl immer die erste, die er findet. Aber wie gesagt, UEFI und ich, wir sind kein Paar.
Was mich am meisten irritiert ist die Tatsache, daß die kurze Benutzung von Windows (was auch immer "kurz" bedeutet) keine Probleme machen soll, die längere jedoch schon. Und das kann ich mir absolut nicht erklären. Irgendein Installations- oder Partitionsfehler müsste doch immer wirken....

viele Grüße gosia
Benutzeravatar

Manfrago
Forum Kenner
Forum Kenner
Beiträge: 107
Registriert: Dienstag 8. Dezember 2020, 17:23
CPU: ausschließlich i7 3.Gen.
GPU: Hybrid
Kernel: 4.19
Desktop-Variante: XFCE
GPU Treiber: Intel/NVIDEA
Hat sich bedankt: 3 Mal
Danksagung erhalten: 7 Mal

Re: WIederkehrender Fehler beim booten

#41

Beitrag von Manfrago »

gosia hat geschrieben: Montag 11. Januar 2021, 21:08 ....Was mich am meisten irritiert ist die Tatsache, daß die kurze Benutzung von Windows (was auch immer "kurz" bedeutet) keine Probleme machen soll, die längere jedoch schon. Und das kann ich mir absolut nicht erklären....
Ich auch nicht, aber hier mal meine "Windows" Erfahrungen.
Ich kann in meinem Bios festlegen, mit welcher Grafikkarte meine Optimus Workstation starten soll. Mit Intel, mit Nvidia oder mit Optimus Unterstützung. Solange ich nur mit Linux arbeite, bleiben meine Vorgaben erhalten. Bin ich aber mit Windows unterwegs, dann wird meine Vorgabe immer auf Optimus zurück gesetzt. Es gibt bei mir auch eine Option im Bios, einem Betriebsystem zu untersagen, Einfluss auf die Bios Einstellungen zu nehmen. Das interessiert Windows 10 aber nicht. Es ändert meine Vorgabe dennoch....
Zuletzt geändert von Manfrago am Montag 11. Januar 2021, 22:06, insgesamt 1-mal geändert.
Ungesicherte Daten sind unwichtige Daten.

Themen Author
DeeBee
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 54
Registriert: Mittwoch 6. Januar 2021, 20:22
CPU: AMD Rzyen 5 2600
GPU: Amd Rx 580 Sapphire Nitro+
Kernel: 5.9.16-1
Desktop-Variante: KDE Plasma
GPU Treiber: Amdgpu

Re: WIederkehrender Fehler beim booten

#42

Beitrag von DeeBee »

Hallo,

Leider gibt es wieder schlechte Neuigkeiten. Ich hab mein PC an gemacht und vergessen f11 zu drücken, um in manjaro zu gehen. Also war ich nur für ein paar sekunden im Windows-Anmeldebildschirm. Ich habe mich allerdings nicht angemeldet, sondern habe direkt neu gestartet, um in Manjaro zu gehen und naja... ohne Erfolg. Der gleiche Fehler ist leider wieder da. Ich meine ich war eben für 2 Stunden in Windows und es war kein Problem... und dann nur für ein paar sekunden und alles ist wieder kaputt :(

Viele Grüße DeeBee
Benutzeravatar

Manfrago
Forum Kenner
Forum Kenner
Beiträge: 107
Registriert: Dienstag 8. Dezember 2020, 17:23
CPU: ausschließlich i7 3.Gen.
GPU: Hybrid
Kernel: 4.19
Desktop-Variante: XFCE
GPU Treiber: Intel/NVIDEA
Hat sich bedankt: 3 Mal
Danksagung erhalten: 7 Mal

Re: WIederkehrender Fehler beim booten

#43

Beitrag von Manfrago »

Was bewirkt F11 bei dir bezüglich der Auswahl eines Betriebssystems unter UEFI?
Ich frage, weil das bei jedem PC unterschiedlich gehandhabt zu sein scheint.
Ungesicherte Daten sind unwichtige Daten.

Themen Author
DeeBee
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 54
Registriert: Mittwoch 6. Januar 2021, 20:22
CPU: AMD Rzyen 5 2600
GPU: Amd Rx 580 Sapphire Nitro+
Kernel: 5.9.16-1
Desktop-Variante: KDE Plasma
GPU Treiber: Amdgpu

Re: WIederkehrender Fehler beim booten

#44

Beitrag von DeeBee »

Naja mit f11 komme ich in das boot menü, also da wo man die verschieden Betriebssysteme auswählen oder von einem Stick booten kann.
Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1430
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
Desktop-Variante: Openbox
GPU Treiber: i915
Hat sich bedankt: 7 Mal
Danksagung erhalten: 242 Mal

Re: WIederkehrender Fehler beim booten

#45

Beitrag von gosia »

Hallo Manfrago,
Manfrago hat geschrieben: Montag 11. Januar 2021, 21:49 Bin ich aber mit Windows unterwegs, dann wird meine Vorgabe immer auf Optimus zurück gesetzt.
Verstehe ich das richtig, dass sich Windows ungefragt in die BIOS-Einstellungen einmischt? Na da, Prost Mahlzeit, dann wundert mich gar nichts mehr.

viele Grüße gosia
Antworten