WIederkehrender Fehler beim booten

Support rund um die Manjaro KDE Edition findet man in dieser Kategorie!
Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1431
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
Desktop-Variante: Openbox
GPU Treiber: i915
Hat sich bedankt: 7 Mal
Danksagung erhalten: 242 Mal

Re: WIederkehrender Fehler beim booten

#16

Beitrag von gosia »

Hallo DeeBee,
DeeBee hat geschrieben: Freitag 8. Januar 2021, 16:49 UEFI? War das nich das mit grafischer Oberfläche und Maus-unterstützung?
Nein, eher das, was Du im BIOS findest.
https://www.ionos.de/digitalguide/serve ... interface/
Du kannst ruhig UEFI benutzen, nur ist eben der Installationsvorgang etwas anders. Dazu noch einen Link
https://wiki.archlinux.de/title/UEFI_Installation
Und wenn ich es richtig sehe, hast Du UEFI. Aber dann brauchst Du auch eine UEFI System Partition /boot/efi
Ob Du die hast, kann ich nicht sehen, für das Bild brauche ich eine Lupe ;)
Bitte keine Bilder, sondern das Zeug als Text hier posten. Erleichtert die Arbeit ungemein. Aber wie gesagt, bei UEFI bin ich schon so gut wie raus...

viele Grüße gosia

Themen Author
DeeBee
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 54
Registriert: Mittwoch 6. Januar 2021, 20:22
CPU: AMD Rzyen 5 2600
GPU: Amd Rx 580 Sapphire Nitro+
Kernel: 5.9.16-1
Desktop-Variante: KDE Plasma
GPU Treiber: Amdgpu

Re: WIederkehrender Fehler beim booten

#17

Beitrag von DeeBee »

Hallo gosia,

Ja sowas dachte ich mir auch, was ein UEFI ist, ich hab das eben einfach nur blöd beschrieben. Naja, hier ist das ganze in Textform :):

Code: Alles auswählen

[manjaro@manjaro ~]$ sudo lsblk --fs
NAME FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0
     squash 4.0                                                    0   100% /run/miso/
loop1
     squash 4.0                                                    0   100% /run/miso/
loop2
     squash 4.0                                                    0   100% /run/miso/
loop3
     squash 4.0                                                    0   100% /run/miso/
sda                                                                         
├─sda1
│    vfat   FAT32       74DD-F327                                           
├─sda2
│    ext4   1.0         397438af-6bf4-4c03-9e37-a5afe8ede61f                
└─sda3
     swap   1           eb4cad31-ebb0-4f4e-a10f-8a694f3dd2c9                
sdb  iso966 Jolie MANJARO_KDE_2021
│                       2021-01-03-09-07-36-00                     0   100% /run/miso/
├─sdb1
│    iso966 Jolie MANJARO_KDE_2021
│                       2021-01-03-09-07-36-00                              
├─sdb2
│    vfat   FAT12 MISO_EFI
│                       7B2D-7571                                           
└─sdb3
     ntfs               5EC06009505B8648                                    
sr0                                                                         
nvme0n1
│                                                                           
├─nvme0n1p1
│    ntfs         Wiederherstellung
│                       5202CC8202CC6C93                                    
├─nvme0n1p2
│    vfat   FAT32       3ECD-B131                                           
├─nvme0n1p3
│                                                                           
├─nvme0n1p4
│    ntfs               A410D8A310D87DAC                                    
└─nvme0n1p5
     ntfs               AE68D34F68D31545                                    
[manjaro@manjaro ~]$ efibootmgr -v
BootCurrent: 000C
Timeout: 1 seconds
BootOrder: 0001,0000,000B,000C,000D,0009
Boot0000* Manjaro       HD(1,GPT,ce5f60a2-3c74-064d-beb9-58664411ce7b,0x1000,0x96000)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0001* Windows Boot Manager  HD(2,GPT,2507b23d-3dec-48c9-a744-077c12b1914f,0xfa000,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...a................
Boot0009* UEFI: Samsung Flash Drive FIT 1100    PciRoot(0x0)/Pci(0x1,0x3)/Pci(0x0,0x0)/USB(0,0)/CDROM(1,0x60247c,0x8000)..BO
Boot000B* UEFI OS       HD(1,GPT,ce5f60a2-3c74-064d-beb9-58664411ce7b,0x1000,0x96000)/File(\EFI\BOOT\BOOTX64.EFI)..BO
Boot000C* UEFI: Samsung Flash Drive FIT 1100, Partition 2       PciRoot(0x0)/Pci(0x1,0x3)/Pci(0x0,0x0)/USB(0,0)/HD(2,MBR,0xaf3aea49,0x60247c,0x2000)..BO
Boot000D* UEFI: Samsung Flash Drive FIT 1100, Partition 3       PciRoot(0x0)/Pci(0x1,0x3)/Pci(0x0,0x0)/USB(0,0)/HD(3,MBR,0xaf3aea49,0x604800,0x717c000)..BO
[manjaro@manjaro ~]$ 
Viele Grüße DeeBee
Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1431
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
Desktop-Variante: Openbox
GPU Treiber: i915
Hat sich bedankt: 7 Mal
Danksagung erhalten: 242 Mal

Re: WIederkehrender Fehler beim booten

#18

Beitrag von gosia »

Hallo DeeBee,
soweit ich das beurteilen kann, sieht das normal aus. Wenn ich es recht sehe, hast Du zwei Festplatten, eine "normale" sda mit Manjaro drauf und eine SSD mit Windows drauf.
Mich irritiert, daß in der Bootreihenfolge als erstes der Windows Boot Manager eingetragen ist und somit auch zuerst startet. Das ist normalerweise kein Problem, wenn aber der Manjaro-Boot-Eintrag dann nicht mehr im Windows-Boot-Menu erscheint aber schon, denn dann kannst Du kein Manjaro mehr starten.
Könnte das bei dir der Fall sein? Wenn Du startest erscheint das Boot-Menu von Windows, Du kannst aber darin kein Manjaro auswählen?
Ich habe bei Ubuntu eine Erklärung gefunden, die ganz gut auch auf Manjaro und dein Problem passen könnte
https://wiki.ubuntuusers.de/EFI_Problem ... nur-einmal
dort gibt es auch einen Lösungsvorschlag (unter "EFI-Eintrag wurde gelöscht oder zerstört")
https://wiki.ubuntuusers.de/EFI_Problem ... -zerstoert
den man sicher auch auf Manjaro übertragen könnte. Allerdings bin ich mir da nicht sicher, weil ich das ganze EFI-Zeugs zu wenig kenne. Ist also ein Vorschlag für andere Experten, die hoffentlich was draus machen können, eine Anleitung oder so.

viele Grüße gosia

Themen Author
DeeBee
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 54
Registriert: Mittwoch 6. Januar 2021, 20:22
CPU: AMD Rzyen 5 2600
GPU: Amd Rx 580 Sapphire Nitro+
Kernel: 5.9.16-1
Desktop-Variante: KDE Plasma
GPU Treiber: Amdgpu

Re: WIederkehrender Fehler beim booten

#19

Beitrag von DeeBee »

Hallo gosia,

Also erstmal habe ich Windows absichtlich als erste startoption festgelegt, da manjaro ja leider nicht funktioniert.
Wenn ich dann aber in manjaro oder von anderen USB sticks booten will, drüche ich bei dem Start des PCs einfach oft f11, damit ich in ein Boot-Menü vom mainboard komme, wo ich meine verschiedenen Bootoptionen habe, aber das müsstest du doch wissen oder? Meinst du dass es deswegen nicht richtig funktioniert, weil ich es nich als erste Startoption festgelegt habe? Oder verstehe ich hier was falsch? Ich denke ich probiere einfach mal einige sachen durch wie z.B. keine swap-Partition erstellen, Manjaro mal auf meine andere SSD installieren und so weiter, villeicht finde ich ja eine Lösung. Achso und was ist mit
"normale" sda
gemeint? Eine "normale" Festplatte, also eine HDD?

Viele Grüße DeeBee
Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1431
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
Desktop-Variante: Openbox
GPU Treiber: i915
Hat sich bedankt: 7 Mal
Danksagung erhalten: 242 Mal

Re: WIederkehrender Fehler beim booten

#20

Beitrag von gosia »

Hallo DeeBee,
DeeBee hat geschrieben: Freitag 8. Januar 2021, 22:46 was ist mit "normale" sda gemeint? Eine "normale" Festplatte, also eine HDD?
genau. Das spielt eigentlich keine Rolle, aber ist es so, daß Du eine HDD und eine SSD verbaut hast?
DeeBee hat geschrieben: Freitag 8. Januar 2021, 22:46 Meinst du dass es deswegen nicht richtig funktioniert, weil ich es nich als erste Startoption festgelegt habe?
Nein, das kann man schon machen. Ich meine das, was in dem Link steht:
"Bei einigen Rechnern geschieht ... folgendes: Die Firmware löscht den Windows-Eintrag, wenn dieser nicht an erster Stelle in der Bootreihenfolge steht. Dies beeinträchtigt den Start von Grub nicht. Sobald Windows startet, bemerkt es den fehlenden Eintrag im NVRAM, erstellt ihn neu und setzt ihn an die erste Stelle in der Bootreihenfolge. Dabei kommt es vor, dass der Manjaro Ubuntu-Eintrag gelöscht wird."
https://wiki.ubuntuusers.de/EFI_Problem ... nur-einmal
Ergebnis: Du kannst Manjaro nicht mehr booten.
Ist aber nur eine Vermutung von mir, ich weiss es nicht mit Sicherheit und kann es auch nicht kontrollieren. Es sieht aber so aus.
DeeBee hat geschrieben: Freitag 8. Januar 2021, 22:46 erstmal habe ich Windows absichtlich als erste startoption festgelegt, da manjaro ja leider nicht funktioniert.
Ja, das verstehe ich schon, und das kann man ja machen. Die Frage ist nur, Konntest Du Manjaro jemals mit dem Grub-Menu booten oder bist Du schon immer den Umweg über F11 und die Veränderung der Bootreihenfolge gegangen?
DeeBee hat geschrieben: Freitag 8. Januar 2021, 22:46 wie z.B. keine swap-Partition erstellen, Manjaro mal auf meine andere SSD installieren
Naja, die SWAP hat wohl nichts damit zu tun und Manjaro neu installiert hast Du ja wohl schon ein paar Mal gemacht. Aber da ich keine brauchbaren Vorschläge machen kann ...
Wäre also nett, wenn sich mal ein Experte zum Problem äussern würde

viele Grüße gosia

Themen Author
DeeBee
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 54
Registriert: Mittwoch 6. Januar 2021, 20:22
CPU: AMD Rzyen 5 2600
GPU: Amd Rx 580 Sapphire Nitro+
Kernel: 5.9.16-1
Desktop-Variante: KDE Plasma
GPU Treiber: Amdgpu

Re: WIederkehrender Fehler beim booten

#21

Beitrag von DeeBee »

Hallo gosia,

Erstmal zu der frage:
ist es so, daß Du eine HDD und eine SSD verbaut hast?
Und nein, eigentlich hab ich nur 2 SSDs verbaut, keine HDD, aber wie du schon gesagt hast, ist das ja eigentlich egal, mich hatte es nur ein bisschen verwundert.
Konntest Du Manjaro jemals mit dem Grub-Menu booten oder bist Du schon immer den Umweg über F11 und die Veränderung der Bootreihenfolge gegangen?
Das habe ich tatsächlich noch nie ausprobiert, wenn mit dem grub menü booten das direkte booten ohne f11 gemeint ist. Was dann noch komisch ist, ist dass ich windows ja eine Zeit lang benutzen kann, bevor manjaro wieder kaputt ist, meistens so um die eine Stunde. Aber wenn ich einfach nur mal kurz in windows rein gehe, ist das kein Problem, was ja heißen müsste dass der Windows Start und das damit verbundene ersetzen vom Starteinträgen ja eigentlich nicht das Problem sein sollte. Auserdem funktioniert der eigentliche Boot-Eintrag von manjaro ja auch immernoch, denn ich komme ja noch in diese Optionen vor dem eigentlichen Start von manjaro, also da wo man die verschiedenen Kernel auswählen kann usw. Wenn ich dann aber in diesem Menü auswähle, dass manjaro starten soll, geht es nicht mehr. Ich probiere es aber gleich mal aus, ob es über das direkte booten funktioniert. Achso und andere distros, wie Ubuntu hatten diesen Fehler nicht, warum ich nicht glaube, dass es irgendwas mit den Starteinträgen zu tun hat. Kann ja aber natürlich trozdem sein.

Viele Grüße DeeBee

Themen Author
DeeBee
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 54
Registriert: Mittwoch 6. Januar 2021, 20:22
CPU: AMD Rzyen 5 2600
GPU: Amd Rx 580 Sapphire Nitro+
Kernel: 5.9.16-1
Desktop-Variante: KDE Plasma
GPU Treiber: Amdgpu

Re: WIederkehrender Fehler beim booten

#22

Beitrag von DeeBee »

Hallo gosia,

So da bin ich nach dem Versuch wieder, aber leider mit schlechten Neuigkeiten, aber villeicht meintest du mit dem booten über das Grub menü ja auch was anderes. Aber ist das Grub menü nich das, wo ich immer rein komme, egal wie ich boote? Ich bin gerade wirklich verwirrt, wie man vielleicht merkt.

Viele Grüße DeeBee
Benutzeravatar

Blueriver
Moderator
Moderator
Beiträge: 2154
Registriert: Donnerstag 19. Mai 2016, 15:49
CPU: AMD Quad Core A8 3,6GHz
GPU: AMD/ATI Radeon R7
Kernel: 5.4
Desktop-Variante: LXQT und XFCE Stable, Testing, Unstable
GPU Treiber: Free
Hat sich bedankt: 14 Mal
Danksagung erhalten: 88 Mal

Re: WIederkehrender Fehler beim booten

#23

Beitrag von Blueriver »

DeeBee hat geschrieben: Freitag 8. Januar 2021, 23:48 Aber ist das Grub menü nich das, wo ich immer rein komme, egal wie ich boote?
Das ist das Grub Menü.
Dateianhänge
Bildschirmfoto_2021-01-09_08-47-38.png
Bildschirmfoto_2021-01-09_08-47-38.png (27.02 KiB) 306 mal betrachtet

Themen Author
DeeBee
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 54
Registriert: Mittwoch 6. Januar 2021, 20:22
CPU: AMD Rzyen 5 2600
GPU: Amd Rx 580 Sapphire Nitro+
Kernel: 5.9.16-1
Desktop-Variante: KDE Plasma
GPU Treiber: Amdgpu

Re: WIederkehrender Fehler beim booten

#24

Beitrag von DeeBee »

Hallo Blueriver

Ja, genau das meine ich. Da komme ich aber immer rein, egal ob ich über f11 oder anders Boote.

Viele Grüße DeeBee
Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 1431
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.19
Desktop-Variante: Openbox
GPU Treiber: i915
Hat sich bedankt: 7 Mal
Danksagung erhalten: 242 Mal

Re: WIederkehrender Fehler beim booten

#25

Beitrag von gosia »

Hallo DeeBee,
ich befürchte, wir befinden uns in einer Sackgasse, oder laufen im Kreis herum, wie man will. Und wenn ich das lese
DeeBee hat geschrieben: Freitag 8. Januar 2021, 23:39 wenn ich einfach nur mal kurz in windows rein gehe, ist das kein Problem
fällt mir nichts mehr ein. Wenn Du also nur kurz mit Windows arbeitest (ca. 5 Minuten???) ist alles in Ordnung und wenn Du, sagen wir mal, mehr als eine Stunde in Windows arbeitest, kannst Du kein Manjaro mehr starten? Nein, ich verstehe die Welt nicht mehr. Keine Ahnung, ich weiss keinen plausiblen Grund dafür und kann dir leider nicht helfen. Tut mir leid, ich gebe auf, bin aber ganz gespannt, was andere dazu meinen.

viele Grüße gosia

Themen Author
DeeBee
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 54
Registriert: Mittwoch 6. Januar 2021, 20:22
CPU: AMD Rzyen 5 2600
GPU: Amd Rx 580 Sapphire Nitro+
Kernel: 5.9.16-1
Desktop-Variante: KDE Plasma
GPU Treiber: Amdgpu

Re: WIederkehrender Fehler beim booten

#26

Beitrag von DeeBee »

Hall gosia,

Code: Alles auswählen

ich befürchte, wir befinden uns in einer Sackgasse, oder laufen im Kreis herum, wie man will.
Ja das gefühl habe ich auch. Und

Code: Alles auswählen

Wenn Du also nur kurz mit Windows arbeitest (ca. 5 Minuten???) ist alles in Ordnung und wenn Du, sagen wir mal, mehr als eine Stunde in Windows arbeitest, kannst Du kein Manjaro mehr starten?
Ja genauso ist es leider.

Code: Alles auswählen

 Keine Ahnung, ich weiss keinen plausiblen Grund dafür und kann dir leider nicht helfen. Tut mir leid, ich gebe auf, bin aber ganz gespannt, was andere dazu meinen.
Ja gut trotzdem vielen Dank für die Versuche und dann hoffe ich auch mal, dass sich mal Jemand mit einer Guten Idee meldet, denn ich würde Manjaro wirklich gerne nutzen.

Viele Grüße DeeBee
Benutzeravatar

LQ
Forum Gott
Forum Gott
Beiträge: 477
Registriert: Donnerstag 5. Januar 2017, 05:43
GPU:
Kernel:
Desktop-Variante:
GPU Treiber:
Hat sich bedankt: 19 Mal
Danksagung erhalten: 91 Mal

Re: WIederkehrender Fehler beim booten

#27

Beitrag von LQ »

gosia hat geschrieben: Samstag 9. Januar 2021, 14:28 fällt mir nichts mehr ein. Wenn Du also nur kurz mit Windows arbeitest (ca. 5 Minuten???) ist alles in Ordnung und wenn Du, sagen wir mal, mehr als eine Stunde in Windows arbeitest, kannst Du kein Manjaro mehr starten? Nein, ich verstehe die Welt nicht mehr. Keine Ahnung, ich weiss keinen plausiblen Grund dafür und kann dir leider nicht helfen. Tut mir leid, ich gebe auf, bin aber ganz gespannt, was andere dazu meinen.
Ich würde fragen, was macht windows nach einer Stunde. ??? :o ^-^

Es wäre doch gut möglich, :-[
daß eine kleine schnuckelige BillBorgGates.exe wach wird, der Borg Tradition folgt
und versucht z.B. ext4 in ntfs umzuwandeln. >:D O:-) ;) :) :D

Folgerichtig wäre das keine manjaro sondern windows Frage. 8)

MfG
"Ceterum censeo M$ esse delendam"

Thatsme
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 91
Registriert: Dienstag 15. September 2020, 10:14
CPU: Quad Core Intel Core i7-3610QM
GPU: NVIDIA GK104GLM [Quadro K4000M]
Kernel: LTS 5.4.85-1
Desktop-Variante: XFCE
GPU Treiber: free-nonfree, kommt darauf an, welcher aktuell funktioniert
Hat sich bedankt: 17 Mal
Danksagung erhalten: 2 Mal

Re: WIederkehrender Fehler beim booten

#28

Beitrag von Thatsme »

Das mit dem Uefi blicke ich auch noch nicht wirklich.
Darum eine blöde Frage. Er schrieb doch, dass er für Manjaro keine Uefi Installation angeben konnte? Bei meiner letzten Install von Manjaro kam ein Hinweis auf Uefi.
Und er hat ja 2 Festplatten.

Ganz am Anfang (screenshot # 10 ) stand doch was von: can not find Grub, check your device map.

Das klingt doch danach, dass evtl. eine Uefi (GPT) und MBR Partitionstabelle existiert? Bzw. dass Manjaro als Biosversion auf der einen Partiton/Festplatte in den MBR installiert wurde und auf der anderen Platte Win im Uefi?
Bzw. die eine FP auf Uefi und die andere im Biosmodus?
Dafür würde auch sprechen, dass er vor dem Boot jeweils auswählt von wo gebootet wird?

Wenn er nun Manjaro im MBR Modus installiert hat, bzw. einen MBR auf die Platte geschrieben hat, das UefiBios aber auf reines Uefi eingestellt ist, oder der CSM Modus nicht richtig funktionert. Kann es sein, dass dann da was durcheinander kommt?

Ich würde mal die "Bios" Einstellungen checken.
Blöd ist, dass Bios und Uefi synonym benutzt wird, da fällt die Unterscheidung schwer.

Die Uefi Sache ist echt kompliziert und es gibt kein genormtes System
http://www.elektronik-kompendium.de/sit ... 901081.htm

https://www.pcwelt.de/ratgeber/PC-vom-K ... 29157.html

https://www.tecchannel.de/a/uefi-tricks ... ,3204883,2
Für die testosterongesteuerten männlichen Wesen:
Erst wenn eine Fliege auf deinen Hoden landet, wirst du lernen Probleme gewaltfrei zu lösen.

Themen Author
DeeBee
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 54
Registriert: Mittwoch 6. Januar 2021, 20:22
CPU: AMD Rzyen 5 2600
GPU: Amd Rx 580 Sapphire Nitro+
Kernel: 5.9.16-1
Desktop-Variante: KDE Plasma
GPU Treiber: Amdgpu

Re: WIederkehrender Fehler beim booten

#29

Beitrag von DeeBee »

Hmm was soll ich denn im bios mal checken? Also welche Einstellungen könnten es sein?

Themen Author
DeeBee
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 54
Registriert: Mittwoch 6. Januar 2021, 20:22
CPU: AMD Rzyen 5 2600
GPU: Amd Rx 580 Sapphire Nitro+
Kernel: 5.9.16-1
Desktop-Variante: KDE Plasma
GPU Treiber: Amdgpu

Re: WIederkehrender Fehler beim booten

#30

Beitrag von DeeBee »

Hallo,

Also ich war gerade nochmal in meinem Bios, und habe eine Option namens "Boot mode select" gefunden. Sie steht auf UEFI, ist aber ausgegraut, also ich kann sie nicht ändern. Das ist doch das, was ihr meintet, was ich mal umstellen soll oder? Und warum ist es ausgegraut?

Viele Grüße DeeBee
Antworten