Bootzeit über 1 Minute

Unser allgemeines Manjaro Linux Diskussionsforum.

Themen Author
Benutzer 797 gelöscht

Bootzeit über 1 Minute

#1

#1 Beitrag von Benutzer 797 gelöscht » Dienstag 18. Dezember 2018, 19:28

Hallo Leute,

in welchem Log, und wo, finde ich einen Hinweis, warum M18 bisher fast immer so lange bootet, bis ich entweder "Esc" tippe oder besser die Maus kurz bewege? Einmal tauchte, wohl kurz nach der MBR-Übergabe, die Fehlermeldung auf, dass ein Update-Prozess läuft und der irgendwie blockiert :o.

Danke euch

snoojo

Benutzeravatar

SGS
Forum Kenner
Forum Kenner
Beiträge: 167
Registriert: Mittwoch 14. März 2018, 21:40
Wohnort: Essen
CPU: Intel Core i7-3770K
GPU: GeForce GTX 1060 6GB
Kernel: > 4.19.46
DE: i3
GPU Treiber: nvidia
Hat sich bedankt: 87 Mal
Danksagung erhalten: 17 Mal
Kontaktdaten:

Re: Bootzeit über 1 Minute

#2

#2 Beitrag von SGS » Dienstag 18. Dezember 2018, 19:29

Schau mal was

Code: Alles auswählen

systemd-analyze blame
anzeigt


Themen Author
Benutzer 797 gelöscht

Re: Bootzeit über 1 Minute

#3

#3 Beitrag von Benutzer 797 gelöscht » Dienstag 18. Dezember 2018, 19:39

Code: Alles auswählen

$ systemd-analyze blame
           461ms upower.service
           433ms udisks2.service
           325ms tlp.service
           247ms systemd-logind.service
           223ms dev-sda1.device
           176ms home.mount
           163ms ModemManager.service
           122ms ldconfig.service
            90ms NetworkManager.service
            89ms polkit.service
            81ms systemd-journald.service
            79ms lvm2-monitor.service
            78ms systemd-udev-trigger.service
            61ms avahi-daemon.service
            61ms systemd-journal-flush.service
            61ms systemd-udevd.service
            52ms user@1000.service
            45ms grub-boot-indeterminate.service
            36ms systemd-fsck@dev-disk-by\x2duuid-6a5d2c22\x2ded05\x2d4180\x2daeed\x2d0>
            31ms systemd-binfmt.service
            31ms dev-disk-by\x2duuid-a55aceda\x2deddb\x2d4d67\x2dae86\x2dd0cb985c44e1.s>
            26ms systemd-modules-load.service
            26ms systemd-tmpfiles-clean.service
            21ms org.cups.cupsd.service
            21ms systemd-journal-catalog-update.service
            21ms systemd-sysusers.service
            18ms systemd-tmpfiles-setup.service
            18ms dev-mqueue.mount
:-\
snoojo


Themen Author
Benutzer 797 gelöscht

Re: Bootzeit über 1 Minute

#4

#4 Beitrag von Benutzer 797 gelöscht » Mittwoch 19. Dezember 2018, 16:29

Eben mal ausprobiert: Kurz nach dem Verschwinden der Bios-Anzeige, die Maus kurz geschubst; und schon taucht mein Desktop auf. Da ich Autologin gewählt habe, schalte ich dieses mal aus, um zu sehen, was dann so passiert.

snoolo

Benutzeravatar

SGS
Forum Kenner
Forum Kenner
Beiträge: 167
Registriert: Mittwoch 14. März 2018, 21:40
Wohnort: Essen
CPU: Intel Core i7-3770K
GPU: GeForce GTX 1060 6GB
Kernel: > 4.19.46
DE: i3
GPU Treiber: nvidia
Hat sich bedankt: 87 Mal
Danksagung erhalten: 17 Mal
Kontaktdaten:

Re: Bootzeit über 1 Minute

#5

#5 Beitrag von SGS » Mittwoch 19. Dezember 2018, 17:10

Könnte an dem neuen quiet grub liegen. Nur das du kein Logo zu Gesicht bekommst.
Ich habe Multiboot (alles Manjaro) und keinen Schimmer davon weil dort nicht vorhanden.


Themen Author
Benutzer 797 gelöscht

Re: Bootzeit über 1 Minute

#6

#6 Beitrag von Benutzer 797 gelöscht » Mittwoch 19. Dezember 2018, 22:22

Werde ich überprüfen. Bisher aber liegt für mich der Grund woanders. Zeitunterschiede von fast 60 Sekunden sind so für mich nicht erklärbar. Meine /-Partition ist 30 GB groß. Die stammt noch aus der openSuse-Zeit als diese auf BtrFs. Ich finde es bis heute genial, eine automatisierte Fallbacklösung zu haben, um kaputte Updates zu umschiffen. Platzgründe können es also nicht sein.

Grüße

snoolo

Benutzeravatar

gosia
Forum Held
Forum Held
Beiträge: 892
Registriert: Dienstag 24. Mai 2016, 13:33
CPU: Intel i5-3210M
GPU: Intel HD 4000
Kernel: 4.15
DE: Openbox
GPU Treiber: i915
Hat sich bedankt: 6 Mal
Danksagung erhalten: 107 Mal

Re: Bootzeit über 1 Minute

#7

#7 Beitrag von gosia » Mittwoch 19. Dezember 2018, 23:46

Hallo snoolo,
snoojo hat geschrieben:
Mittwoch 19. Dezember 2018, 22:22
Bisher aber liegt für mich der Grund woanders
Tja, könnte sein. Deine angezeigten Bootzeiten sind ja so schlimm nicht, geschätzt würde ich sagen zusammen etwa 5..10 Sekunden. Genau würde man das durch die Eingabe von

Code: Alles auswählen

systemd-analyze & systemd-analyze blame
sehen, welche Startup-Zeiten insgesamt für Kernel und Userspace verbraten wurden.

Code: Alles auswählen

systemd-analyze critical-chain
gibt dann zusätzlich Hinweise, wo es am meisten klemmt. Auch

Code: Alles auswählen

journalctl -b _PID=1
könnte Hinweise bringen.
Du kannst auch nachsehen, ob tatsächlich alle Dienste gebraucht werden und die nicht benötigten abschalten. ModemManager.service wäre z.B. so ein Kandidat, wenn Du kein mobiles Broadband Interface brauchst. Aber nach deinen Zeiten bringt das maximal eine Sekunde, also da ist nicht viel zu schrauben. Trotzdem dieser Link
https://wiki.archlinux.org/index.php/Im ... ot_process
kann ja nicht schaden.
Aber ich denke eher in die Richtung Display Manager (welchen benutzt Du denn?). Und ja, schalte mal das Autologin ab weg mit solchen Spielereien wie dem Boot-Splash (Plymouth), wenn Du den verwendest. Freier Blick auf den Boot-Vorgang ist immer nützlich.

viele Grüße gosia

Benutzeravatar

SGS
Forum Kenner
Forum Kenner
Beiträge: 167
Registriert: Mittwoch 14. März 2018, 21:40
Wohnort: Essen
CPU: Intel Core i7-3770K
GPU: GeForce GTX 1060 6GB
Kernel: > 4.19.46
DE: i3
GPU Treiber: nvidia
Hat sich bedankt: 87 Mal
Danksagung erhalten: 17 Mal
Kontaktdaten:

Re: Bootzeit über 1 Minute

#8

#8 Beitrag von SGS » Donnerstag 20. Dezember 2018, 00:35

Wenn es heute länger als 10 Sekunden dauert macht man sich Sorgen, damals im alten Berlin ;) hat man den Rechner angemacht und die Kaffeemaschine gestartet, wenn der Kaffee dann abgekühlt war lief die Kiste auch schon ;)


Komisch ist halt das mit der Mausschupserei und der Bildschirm wacht auf, ist da was am Monitor einzustellen?

Benutzeravatar

linuxkumpel
Forum Held
Forum Held
Beiträge: 601
Registriert: Montag 23. Mai 2016, 17:29
Wohnort: Strausberg | M
CPU: Intel Core i3-4030U 4x 1.8GHz 64 bit
GPU: Intel Haswell-ULT (Intel HD Graphics 4400)
Kernel: 4.19 / 5.3
DE: Manjaro 18.1.0 Juhraya Xfce 4.14.1
GPU Treiber: Intel i915
Hat sich bedankt: 11 Mal
Danksagung erhalten: 31 Mal
Kontaktdaten:

Re: Bootzeit über 1 Minute

#9

#9 Beitrag von linuxkumpel » Donnerstag 20. Dezember 2018, 08:21

SGS hat geschrieben:
Donnerstag 20. Dezember 2018, 00:35
Wenn es heute länger als 10 Sekunden dauert macht man sich Sorgen, ...
Der ist gut. ;)

Ich liege auch so beim ersten Start um eine Minute, beunruhigt mich allerdings nicht, halt HDD und keine SSD. Längste Zeit brauch dann wirklich der sog. userspace (Benutzerbereich). Alles andere um die 7-5 sec.

Benutzeravatar

OlliFri
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 70
Registriert: Sonntag 15. Mai 2016, 11:37
Wohnort: Oranienburg
CPU: AMD Phenom 9650 4 Kerne
GPU: NVIDIA GF119 - GeForce GT 610
Kernel: 5.XX
DE: Deepin
GPU Treiber: NVIDIA 390.116
Hat sich bedankt: 1 Mal
Danksagung erhalten: 5 Mal

Re: Bootzeit über 1 Minute

#10

#10 Beitrag von OlliFri » Donnerstag 20. Dezember 2018, 09:19

Hi,
Ich sehe gerade das bei dir der "haveged.service" nicht läuft.
Ohne den kommt es zu diesem merkwürdigen Verhalten.
Installiere mal "haveged" und starte neu.


Themen Author
Benutzer 797 gelöscht

Re: Bootzeit über 1 Minute

#11

#11 Beitrag von Benutzer 797 gelöscht » Donnerstag 20. Dezember 2018, 16:35

Hallo hier,

eben mal ausprobiert: Gleich nach dem Einschalten die Maus immer leicht bewegt (schon während des Bios) und siehe da: Nach dem Bios schätze ich mal 5 Sekunden und ich auf auf dem KDM.

Ich werde haveged.service noch installieren und dann gespannt sein :D.

Grüße eines

snoojo

Benutzeravatar

OlliFri
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 70
Registriert: Sonntag 15. Mai 2016, 11:37
Wohnort: Oranienburg
CPU: AMD Phenom 9650 4 Kerne
GPU: NVIDIA GF119 - GeForce GT 610
Kernel: 5.XX
DE: Deepin
GPU Treiber: NVIDIA 390.116
Hat sich bedankt: 1 Mal
Danksagung erhalten: 5 Mal

Re: Bootzeit über 1 Minute

#12

#12 Beitrag von OlliFri » Donnerstag 20. Dezember 2018, 16:54

haveged installieren, haveged.service gibt es nicht als Paket
Zuletzt geändert von OlliFri am Donnerstag 20. Dezember 2018, 16:56, insgesamt 1-mal geändert.

Benutzeravatar

OlliFri
Erfahrenes Foren Mitglied
Erfahrenes Foren Mitglied
Beiträge: 70
Registriert: Sonntag 15. Mai 2016, 11:37
Wohnort: Oranienburg
CPU: AMD Phenom 9650 4 Kerne
GPU: NVIDIA GF119 - GeForce GT 610
Kernel: 5.XX
DE: Deepin
GPU Treiber: NVIDIA 390.116
Hat sich bedankt: 1 Mal
Danksagung erhalten: 5 Mal

Re: Bootzeit über 1 Minute

#13

#13 Beitrag von OlliFri » Donnerstag 20. Dezember 2018, 16:54

Da kann ich ja nur hoffen das es klappt.
Nicht das ich noch Kloppe kriege. :)
Nee, Spass bei Seite. Wenn Du die Maus bewegst erzeugst Du quasi Zufallszahlen die das System beim Start braucht.
Für gewohlich sorgt dafür haveged.
Ist jetzt mal nur super einfach erklärt.


Themen Author
Benutzer 797 gelöscht

Re: Bootzeit über 1 Minute

#14

#14 Beitrag von Benutzer 797 gelöscht » Donnerstag 20. Dezember 2018, 17:09

Supereinfach, genau so beginnt es. Daaaaaankeeeeee


Themen Author
Benutzer 797 gelöscht

Re: Bootzeit über 1 Minute

#15

#15 Beitrag von Benutzer 797 gelöscht » Donnerstag 20. Dezember 2018, 17:21

O.k. also Octopi erzählt mir, haveged ist aus dem extra-Repo installiert worden.

Bei meinem ersten Überflug übers Wiki fand ich nichts zu haveged, denn ich gehe mal davon aus, dass dieser Dienst automatisch gestartet werden muss.

H2D? How to do?

snoojo

P.s.: Gerade im verlinkten Wiki gelesen, dass ich mit "systemctl enable haveged" das Problem beseitigen können müsste. Wenn ja, wo dann??

Antworten