Autor Thema: SABnzb zickt...  (Gelesen 184 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Der_Jochen

  • Neues Foren Mitglied
  • *
  • Beiträge: 32
  • CPU: AMD A10-9700 Radeon
  • GPU: ?
  • Kernel: 4.15.0
  • DE: ?
  • GPU Treiber: ?
SABnzb zickt...
« am: 02. Oktober 2018, 14:48:15 »
Hallo,
nach längerer Abstinenz mal wieder ein Lesezeichen von mir:

Heute habe ich den großen Sprung gewagt und Manjaro auf meinem Hauptrechner installiert. Und das "Üben" am Laptop hat sich gelohnt... nach drei Stunden läuft es alles schon weitestgehend so wie ich mir das vorstelle.
Aber ein kleines Problem tut sich noch auf: Ich habe den Usenet-Grabber SABnzb installiert. Allerdings bekomme ich ihn nicht zum Laufen: Er sollte normalerweise im Browser unter der Adresse "http://127.0.0.1:8080/sabnzbd/" eine Oberfläche anzeigen. Firefox teilt mir jedoch eine fehlgeschlagene Verbindung mit.
Auf dem Laptop hat es damals nach einem Neustart funktioniert. Auf meinem "Großen" klappt es so leider nicht. Habt ihr evtl eine Idee?

Herzliche Grüße
Der_Jochen 
 

gosia

  • Forum Held
  • *****
  • Beiträge: 569
  • Dankeschön: 155 mal
  • CPU: Intel® Core™ i5-3210M
  • GPU: Intel HD 4000
  • Kernel: 4.9. (Artix)
  • DE: OpenBox + xfce
Re: SABnzb zickt...
« Antwort #1 am: 02. Oktober 2018, 18:15:01 »
Hallo Jochen,
läuft sabnzbd per systemd oder hast Du den Dienst von Hand gestartet? Oder anders gefragt, läuft der Dienst (Status überprüfen)
systemctl status sabnzbd.serviceUnd wenn ich diese Anleitung richtig verstehe
https://wiki.archlinux.org/index.php/SABnzbd
ist die URL für das Webinterface einfach
127.0.0.1:8080
es sei denn, Du hast in der opt/sabnzbd/sabnzbd.ini was anderes eingestellt. Also starte den Browser nochmals, nur mit
http://127.0.0.1:8080
und poste eventuell die genaue Fehlermeldung mit Statuscode, z.B. "404 Not found" oder was immer der Bursche meldet.
Ach ja, hast Du dich in die Gruppe sabnzbd eingetragen?

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung...
 
Folgende Mitglieder bedankten sich: Der_Jochen

Der_Jochen

  • Neues Foren Mitglied
  • *
  • Beiträge: 32
  • CPU: AMD A10-9700 Radeon
  • GPU: ?
  • Kernel: 4.15.0
  • DE: ?
  • GPU Treiber: ?
Re: SABnzb zickt...
« Antwort #2 am: 02. Oktober 2018, 18:30:08 »
Hallo GOSIA,

danke für deine Antwort.

systemctl status sabnzbd.service
sagt:

systemctl status sabnzbd.service
 sabnzbd.service - SABnzbd binary newsreader
   Loaded: loaded (/usr/lib/systemd/system/sabnzbd.service; disabled; vendor pr>
   Active: inactive (dead)

Ich starte den Dienst händisch über das Whisker-Menü. Natürlich sollte er bei Systemstart automatisch starten. da muss ich noch einmal sehen, wie ich ihn in den Autostart bekomme.

Bei der Installation habe ich nicht bewusst eine Gruppe angelegt oder mich eingetragen. Ich habe das in der Doku gesehen, bin aber ehrlich gesagt nicht so richtig schlau daraus geworden. Vielleicht kannst du mir da auf die Sprünge helfen?

Wenn ich https://127.0.0.1:8080 in die Adresszeile eingebe bringt FF die Meldung "Fehler: Verbindung fehlgeschlagen

Firefox kann keine Verbindung zu dem Server unter 127.0.0.1:8080 aufbauen.

    "Die Website könnte vorübergehend nicht erreichbar sein, versuchen Sie es bitte später nochmals.
    Wenn Sie auch keine andere Website aufrufen können, überprüfen Sie bitte die Netzwerk-/Internetverbindung.
    Wenn Ihr Computer oder Netzwerk von einer Firewall oder einem Proxy geschützt wird, stellen Sie bitte sicher, dass Firefox auf das Internet zugreifen darf."

Ach ja, Firewall ist ausgeschaltet.

Viele Grüße
Jochen
 

Daemon

  • Erfahrenes Foren Mitglied
  • **
  • Beiträge: 73
  • Dankeschön: 28 mal
  • CPU: AMD Ryzen
  • GPU: AMD
  • Kernel: 4.15 (ck-zen)
  • DE: KDE Plasma
  • GPU Treiber: AMD
Re: SABnzb zickt...
« Antwort #3 am: 02. Oktober 2018, 19:10:32 »
systemctl enable sabnzbd.service
startet den Dienst direkt und
systemctl start sabnzbd.service
startet den Dienst im autostart
 
Folgende Mitglieder bedankten sich: Der_Jochen

gosia

  • Forum Held
  • *****
  • Beiträge: 569
  • Dankeschön: 155 mal
  • CPU: Intel® Core™ i5-3210M
  • GPU: Intel HD 4000
  • Kernel: 4.9. (Artix)
  • DE: OpenBox + xfce
Re: SABnzb zickt...
« Antwort #4 am: 02. Oktober 2018, 19:40:58 »
Hallo Jochen,
Ich starte den Dienst händisch über das Whisker-Menü.
um sicherzugehen würde ich den Dienst erstmal wie von Daemon vorgeschlagen per Hand starten
sudo systemctl start sabnzbd.serviceund gleich danach wie gehabt, den Status überprüfen. Wenn da was nicht stimmt, brauchst Du gar nicht erst den Browser aufzumachen.
Bei der Installation habe ich nicht bewusst eine Gruppe angelegt oder mich eingetragen. Ich habe das in der Doku gesehen, bin aber ehrlich gesagt nicht so richtig schlau daraus geworden. Vielleicht kannst du mir da auf die Sprünge helfen?
Das ist wahrscheinlich erst wichtig, wenn der Dienst läuft, aber schaden kann es sicher auch nicht. Userverwaltung geht am einfachsten über den Manjaro Settings Manager
https://wiki.manjaro.org/index.php?title=Manjaro_Settings_Manager
aber da Du sicher auch was in der Kommandozeile tun und lernen willst  8)
sudo usermod -aG GRUPPE USERüberflüssig zu betonen, daß GRUPPE und USER mit den entsprechenden Namen angepasst werden müssen.

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung...
 
Folgende Mitglieder bedankten sich: Der_Jochen

Der_Jochen

  • Neues Foren Mitglied
  • *
  • Beiträge: 32
  • CPU: AMD A10-9700 Radeon
  • GPU: ?
  • Kernel: 4.15.0
  • DE: ?
  • GPU Treiber: ?
Re: SABnzb zickt...
« Antwort #5 am: 02. Oktober 2018, 21:59:56 »
Nachdem ich leider das gesamte System neu installieren musste und folglich auch SABnzbd neu installiert habe (man lernt ja ständig... diesmal über yaourt installiert und nicht über AUR) funktioniert es nun plötzlich. Allerdings nur über http, leider nicht mit https... aber damit kann ich notfalls leben.

Danke für eure Hilfe :-))
 

gosia

  • Forum Held
  • *****
  • Beiträge: 569
  • Dankeschön: 155 mal
  • CPU: Intel® Core™ i5-3210M
  • GPU: Intel HD 4000
  • Kernel: 4.9. (Artix)
  • DE: OpenBox + xfce
Re: SABnzb zickt...
« Antwort #6 am: 02. Oktober 2018, 23:24:24 »
Hallo Jochen,
Allerdings nur über http, leider nicht mit https.
In der Konfigurationsdatei unter "Webserver" -> "Enable HTTPS"
https://sabnzbd.org/wiki/configuration/2.3/general#toc1
https://sabnzbd.org/wiki/advanced/https

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung...
 
Folgende Mitglieder bedankten sich: Der_Jochen

Der_Jochen

  • Neues Foren Mitglied
  • *
  • Beiträge: 32
  • CPU: AMD A10-9700 Radeon
  • GPU: ?
  • Kernel: 4.15.0
  • DE: ?
  • GPU Treiber: ?
Re: SABnzb zickt...
« Antwort #7 am: 03. Oktober 2018, 09:12:05 »
Hallo und guten Morgen,

leider habe ich mir mit dem Versuch, https einzurichten das Programm wieder zerschossen. Habe es über die Softwareverwaltung daher deinstalliert und mit yaourt neu installiert. Allerdings hat er wohl Probleme mit dem Start.

Ich bekomme diese Fehlermeldung:

systemctl status sabnzbd.service
● sabnzbd.service - SABnzbd binary newsreader
   Loaded: loaded (/usr/lib/systemd/system/sabnzbd.service; enabled; vendor pre>
   Active: [color=red]failed [/color](Result: exit-code) since Wed 2018-10-03 08:45:25 CEST; 20min>
 Main PID: 1621 (code=exited, status=70)

Okt 03 08:45:25 jochen-pc SABnzbd.py[1621]:     self.publish('start')
Okt 03 08:45:25 jochen-pc SABnzbd.py[1621]:   File "/opt/sabnzbd/cherrypy/proce>
Okt 03 08:45:25 jochen-pc SABnzbd.py[1621]:     level=40, traceback=True)
Okt 03 08:45:25 jochen-pc SABnzbd.py[1621]:   File "/opt/sabnzbd/cherrypy/proce>
Okt 03 08:45:25 jochen-pc SABnzbd.py[1621]:     self.publish('log', msg, level)
Okt 03 08:45:25 jochen-pc SABnzbd.py[1621]:   File "/opt/sabnzbd/cherrypy/proce>
Okt 03 08:45:25 jochen-pc SABnzbd.py[1621]:     raise exc
Okt 03 08:45:25 jochen-pc SABnzbd.py[1621]: ChannelFailures: TypeError('not eno>
Okt 03 08:45:25 jochen-pc systemd[1]: sabnzbd.service: Main process exited, cod>
Okt 03 08:45:25 jochen-pc systemd[1]: sabnzbd.service: Failed with result 'exit>
 

Gibt es ggf. Alternativen? Ich bin im Netz auf nzbget gestossen. Es ist auch in Manajro als Softwarepaket enthalten. Ich habe es installiert aber keinen Schimmer, wie ich es zum Laufen kriege.
Danke für eure Hilfe und einen schönen Feiertag.
 

Blueriver

  • Moderator
  • *****
  • Beiträge: 1610
  • Dankeschön: 206 mal
  • CPU: AMD Quad Core A8 3,6GHz
  • GPU: AMD/ATI Radeon R7
  • Kernel: 4.19
  • DE: LXQT und XFCE Stable, Testing, Unstable
  • GPU Treiber: Free
Re: SABnzb zickt...
« Antwort #8 am: 03. Oktober 2018, 11:15:11 »
Gibt es ggf. Alternativen? Ich bin im Netz auf nzbget gestossen. Es ist auch in Manajro als Softwarepaket enthalten. Ich habe es installiert aber keinen Schimmer, wie ich es zum Laufen kriege.
Danke für eure Hilfe und einen schönen Feiertag.
Siehe mal hier
https://wiki.archlinux.org/index.php/NZBGet
Manjaro LXQT und XFCE Stable, Testing, Unstable
CPU: AMD Quad Core A8 3,6GHz
Graka: AMD/ATI Radeon R7
Treiber: Free
Kernel: 4.19
 
Folgende Mitglieder bedankten sich: Der_Jochen

Der_Jochen

  • Neues Foren Mitglied
  • *
  • Beiträge: 32
  • CPU: AMD A10-9700 Radeon
  • GPU: ?
  • Kernel: 4.15.0
  • DE: ?
  • GPU Treiber: ?
Re: SABnzb zickt...
« Antwort #9 am: 03. Oktober 2018, 12:22:18 »
Hallo Blueriver,
danke für den Link.

Ich habe es zum Laufen gekriegt. Es ist zwar nicht so komfortabel wie SABnzb (man muss es immer manuell über die Konsole starten) - aber immerhin... es funktioniert  ???