Autor Thema: Update nicht möglich  (Gelesen 611 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Dieses Thema beinhaltet einen Beitrag mit der besten Antwort. Hier drücken um es zu sehen.

Peter

  • Forum Kenner
  • ***
  • Beiträge: 116
  • Dankeschön: 1 mal
  • CPU: Intel Core i5-6200U CPU @ 2.30GHz
  • GPU: NVIDIA GeForce 940MX
  • Kernel: 4.14.34-1-MANJARO x86_64
  • DE: KDE Plasma 5.12.4
  • GPU Treiber: video-hybrid-intel-nvidia-bumblebee
Update nicht möglich
« am: 03. Februar 2018, 20:47:52 »
Habe auf TTY3 sudo pacman -Syu eingegeben.
Folgende Fehlermeldung:
Warnung: linux-rt-lts-manjaro-nvidia: Lokale Version (1:384.98-5) ist neuer als community (4.14-1)
Warnung: linux-rt-lts-manjaro-r8168: Lokale Version (8.044.02-11) ist neuer als community (4.14-1)
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: linux-rt-lts-manjaro-nvidia: das Installieren von nvidia-utils (1:384.111-3) verletzt Abhängigkeit von 'nvidia-utils=1:384.98'
:: linux413-nvidia: das Installieren von nvidia-utils (1:384.111-3) verletzt Abhängigkeit von 'nvidia-utils=1:384.98'

Was ist zu tun?
 

Blueriver

  • Moderator
  • *****
  • Beiträge: 1368
  • Dankeschön: 180 mal
  • CPU: AMD Quad Core A8 3,6GHz
  • GPU: AMD/ATI Radeon R7
  • Kernel: 4.16
  • DE: LXQT und XFCE Stable, Testing, Unstable
  • GPU Treiber: Free
Re: Update nicht möglich
« Antwort #1 am: 03. Februar 2018, 22:12:31 »
Nimm mal einen anderen Kernel und lösch den 4.13, der Kernel 4.13 ist eol.

Danach noch ein
sudo pacman -Syyuu
Manjaro LXQT und XFCE Stable, Testing, Unstable
CPU: AMD Quad Core A8 3,6GHz
Graka: AMD/ATI Radeon R7
Treiber: Free
Kernel: 4.16
 

Peter

  • Forum Kenner
  • ***
  • Beiträge: 116
  • Dankeschön: 1 mal
  • CPU: Intel Core i5-6200U CPU @ 2.30GHz
  • GPU: NVIDIA GeForce 940MX
  • Kernel: 4.14.34-1-MANJARO x86_64
  • DE: KDE Plasma 5.12.4
  • GPU Treiber: video-hybrid-intel-nvidia-bumblebee
Re: Update nicht möglich
« Antwort #2 am: 03. Februar 2018, 22:43:27 »
Geht leider nicht. Wollte den lts Kernel 4.14.16-1 installieren über Kernel Systemeinstellungen. Folgende Fehlermeldung:
The following packages will be installed:
linux414
linux414-ndiswrapper
linux414-r8168
linux414-bbswitch
linux414-nvidia
Starting
resolving dependencies...
looking for conflicting packages...
:: linux-rt-lts-manjaro-nvidia: installing nvidia-utils (1:384.111-3) breaks dependency 'nvidia-utils=1:384.98'
error: failed to prepare transaction (could not satisfy dependencies)
:: linux413-nvidia: installing nvidia-utils (1:384.111-3) breaks dependency 'nvidia-utils=1:384.98'
:: linux44-nvidia: installing nvidia-utils (1:384.111-3) breaks dependency 'nvidia-utils=1:384.98'


Fertig ...
 

Peter

  • Forum Kenner
  • ***
  • Beiträge: 116
  • Dankeschön: 1 mal
  • CPU: Intel Core i5-6200U CPU @ 2.30GHz
  • GPU: NVIDIA GeForce 940MX
  • Kernel: 4.14.34-1-MANJARO x86_64
  • DE: KDE Plasma 5.12.4
  • GPU Treiber: video-hybrid-intel-nvidia-bumblebee
Re: Update nicht möglich
« Antwort #3 am: 03. Februar 2018, 23:06:10 »
Hab einen anderen Kernel gebootet 4.9.68-1-rt60-MANJARO x86_64 und dann den 4.13 Kernel deinstalliert.
Dann wollte ich den lts 4.14.16-1 installieren. Folgende Fehlermeldung:

The following packages will be installed:
linux414
linux414-bbswitch
linux414-nvidia
linux414-r8168
linux414-ndiswrapper

Starting
resolving dependencies...
looking for conflicting packages...
:: linux-rt-lts-manjaro-nvidia: installing nvidia-utils (1:384.111-3) breaks dependency 'nvidia-utils=1:384.98'
error: failed to prepare transaction (could not satisfy dependencies)
:: linux44-nvidia: installing nvidia-utils (1:384.111-3) breaks dependency 'nvidia-utils=1:384.98'


Fertig ...

Der Kernel, den ich jetzt gebootet habe, taucht auch gar nicht in der Liste bei Systemeinstellungen - Kernel auf. Ist im Bootmanager aber auswählbar.
Dafür wird bei Systemeinstellungen - Kernel ein 4.14-1 rt Kernel als installiert angezeigt, der im Bootmanager nicht angezeigt wird.
Ich habe jetzt nur noch den Kernel 4.4.114-1 installiert, der sowohl im Bootmanager als auch bei Systemeinstellungen - Kernel angezeigt wird.

Hilfe!
« Letzte Änderung: 03. Februar 2018, 23:14:09 von Peter »
 

Daemon

  • Erfahrenes Foren Mitglied
  • **
  • Beiträge: 52
  • Dankeschön: 19 mal
  • CPU: AMD Ryzen
  • GPU: nVidia
  • Kernel: 4.15 (ck-zen)
  • DE: KDE Plasma
  • GPU Treiber: nVidia
Re: Update nicht möglich
« Antwort #4 am: 03. Februar 2018, 23:19:08 »
Deinstalliere die Sachen von nVidia, deinstalliere die Kernel die du nicht mehr brauchst, installiere den neuen Kernel, installiere die nVidia Sachen wieder.
 

Peter

  • Forum Kenner
  • ***
  • Beiträge: 116
  • Dankeschön: 1 mal
  • CPU: Intel Core i5-6200U CPU @ 2.30GHz
  • GPU: NVIDIA GeForce 940MX
  • Kernel: 4.14.34-1-MANJARO x86_64
  • DE: KDE Plasma 5.12.4
  • GPU Treiber: video-hybrid-intel-nvidia-bumblebee
Re: Update nicht möglich
« Antwort #5 am: 03. Februar 2018, 23:22:41 »
Deinstalliere die Sachen von nVidia, deinstalliere die Kernel die du nicht mehr brauchst, installiere den neuen Kernel, installiere die nVidia Sachen wieder.
Wie muss ich das machen?
Bis gestern bekam ich übrigens die Meldung, dass 85 Updates zur Installation bereitstehen. Heute sind es schon 422.

Bei octopi hab ich mal nach nvidia gesucht. da taucht gleich oben ein Paket auf linux-rt-lts-manjaro-nvidia mit der Info:
Version 4.14-1 (neuere installierte Version ist 1:384.98-5)
Anscheinend hab ich neuere Pakete, als auf dem Updateserver angeboten werden... Ist der Updateserver evtl. noch beim syncen oder so?
« Letzte Änderung: 03. Februar 2018, 23:35:31 von Peter »
 

Daemon

  • Erfahrenes Foren Mitglied
  • **
  • Beiträge: 52
  • Dankeschön: 19 mal
  • CPU: AMD Ryzen
  • GPU: nVidia
  • Kernel: 4.15 (ck-zen)
  • DE: KDE Plasma
  • GPU Treiber: nVidia
Re: Update nicht möglich
« Antwort #6 am: 04. Februar 2018, 00:12:06 »
Wie muss ich das machen?
Bis gestern bekam ich übrigens die Meldung, dass 85 Updates zur Installation bereitstehen. Heute sind es schon 422.
Wann hast du das letzte mal ein Update gemacht? Bei einer Rolling-Release Distribution kann das sehr schnell nach hinten los ganzen wenn man so viele Updates anstauen lässt (wie du siehst). Evtl. wäre eine Debian basierte Distro besser geeignet für dich?
Und bitte, ein Update macht man nicht über so ein Quatsch wie Octopi.

Was du machen musst?
Terminal öffnen -> sudo pacman -Syu
Die komplette Ausgabe vom Terminal hier einfügen (in einem Code Block).
 

Peter

  • Forum Kenner
  • ***
  • Beiträge: 116
  • Dankeschön: 1 mal
  • CPU: Intel Core i5-6200U CPU @ 2.30GHz
  • GPU: NVIDIA GeForce 940MX
  • Kernel: 4.14.34-1-MANJARO x86_64
  • DE: KDE Plasma 5.12.4
  • GPU Treiber: video-hybrid-intel-nvidia-bumblebee
Re: Update nicht möglich
« Antwort #7 am: 04. Februar 2018, 02:20:28 »
Wann hast du das letzte mal ein Update gemacht? Bei einer Rolling-Release Distribution kann das sehr schnell nach hinten los ganzen wenn man so viele Updates anstauen lässt (wie du siehst). Evtl. wäre eine Debian basierte Distro besser geeignet für dich?
Und bitte, ein Update macht man nicht über so ein Quatsch wie Octopi.

Was du machen musst?
Terminal öffnen -> sudo pacman -Syu
Die komplette Ausgabe vom Terminal hier einfügen (in einem Code Block).
Das letzte Update war am 1. Januar 2018.
[peter@peter-akoya ~]$ sudo pacman -Syu
[sudo] Passwort für peter:
:: Synchronisiere Paketdatenbanken...
 core ist aktuell
 extra ist aktuell
 community                                                    4,3 MiB   460K/s 00:10 [################################################] 100%
 multilib ist aktuell
 herecura ist aktuell
:: Starte vollständige Systemaktualisierung...
Warnung: libinput: Ignoriere Paket-Aktualisierung (1.6.3-1 => 1.9.4-1)
Warnung: linux-rt-lts-manjaro-nvidia: Lokale Version (1:384.98-5) ist neuer als community (4.14-1)
Warnung: linux-rt-lts-manjaro-r8168: Lokale Version (8.044.02-11) ist neuer als community (4.14-1)
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: linux-rt-lts-manjaro-nvidia: das Installieren von nvidia-utils (1:384.111-3) verletzt Abhängigkeit von 'nvidia-utils=1:384.98'
[peter@peter-akoya ~]$
 

Markiert als beste Antwort von Peter am 07. Februar 2018, 01:25:16

Blueriver

  • Moderator
  • *****
  • Beiträge: 1368
  • Dankeschön: 180 mal
  • CPU: AMD Quad Core A8 3,6GHz
  • GPU: AMD/ATI Radeon R7
  • Kernel: 4.16
  • DE: LXQT und XFCE Stable, Testing, Unstable
  • GPU Treiber: Free
Re: Update nicht möglich
« Antwort #8 am: 04. Februar 2018, 08:49:12 »
Danach noch ein
sudo pacman -Syyuu
Hast du leider noch nicht gemacht.


PS: Die Fragen dann mit ja bestätigen.
« Letzte Änderung: 04. Februar 2018, 08:57:13 von Blueriver »
Manjaro LXQT und XFCE Stable, Testing, Unstable
CPU: AMD Quad Core A8 3,6GHz
Graka: AMD/ATI Radeon R7
Treiber: Free
Kernel: 4.16
 
Folgende Mitglieder bedankten sich: Peter

Peter

  • Forum Kenner
  • ***
  • Beiträge: 116
  • Dankeschön: 1 mal
  • CPU: Intel Core i5-6200U CPU @ 2.30GHz
  • GPU: NVIDIA GeForce 940MX
  • Kernel: 4.14.34-1-MANJARO x86_64
  • DE: KDE Plasma 5.12.4
  • GPU Treiber: video-hybrid-intel-nvidia-bumblebee
Re: Update nicht möglich
« Antwort #9 am: 04. Februar 2018, 09:29:41 »
Hast du leider noch nicht gemacht.


PS: Die Fragen dann mit ja bestätigen.
Ich dachte ich muss erst einen neueren Kernel installieren.

Es könnte funktionieren aber es gibt ein Downgrade von Paketen. Folgende Warnungen werden noch angezeigt:
Warnung: linux-rt-lts-manjaro-nvidia: Downgrade von Version 1:384.98-5 zu Version 4.14-1
Warnung: linux-rt-lts-manjaro-r8168: Downgrade von Version 8.044.02-11 zu Version 4.14-1
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: mesa wird vor seiner Abhängigkeit libglvnd installiert werden
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: nvidia-utils wird vor seiner Abhängigkeit libglvnd installiert werden
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: xorg-server wird vor seiner Abhängigkeit libglvnd installiert werden
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: harfbuzz wird vor seiner Abhängigkeit freetype2 installiert werden
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: lib32-mesa wird vor seiner Abhängigkeit lib32-libglvnd installiert werden
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: lib32-nvidia-utils wird vor seiner Abhängigkeit lib32-libglvnd installiert werden


Momentan bin ich aber nur an einem Freifunk-Wlan was sehr langsam ist und immer mal Aussetzer hat. Ich muss erst wieder einen Kumpel besuchen fahren für das Update.
 

Blueriver

  • Moderator
  • *****
  • Beiträge: 1368
  • Dankeschön: 180 mal
  • CPU: AMD Quad Core A8 3,6GHz
  • GPU: AMD/ATI Radeon R7
  • Kernel: 4.16
  • DE: LXQT und XFCE Stable, Testing, Unstable
  • GPU Treiber: Free
Re: Update nicht möglich
« Antwort #10 am: 04. Februar 2018, 10:27:32 »
Downgrades der Pakete ist richtig.
Mit ja bestätigen und weiter.
Manjaro LXQT und XFCE Stable, Testing, Unstable
CPU: AMD Quad Core A8 3,6GHz
Graka: AMD/ATI Radeon R7
Treiber: Free
Kernel: 4.16
 

Peter

  • Forum Kenner
  • ***
  • Beiträge: 116
  • Dankeschön: 1 mal
  • CPU: Intel Core i5-6200U CPU @ 2.30GHz
  • GPU: NVIDIA GeForce 940MX
  • Kernel: 4.14.34-1-MANJARO x86_64
  • DE: KDE Plasma 5.12.4
  • GPU Treiber: video-hybrid-intel-nvidia-bumblebee
Re: Update nicht möglich
« Antwort #11 am: 07. Februar 2018, 01:24:36 »
sudo pacman -Syyuuhat funktioniert.
Danach konnte ich auch einen weiteren Kernel installieren.

Besten Dank!