Autor Thema: Fehler beim Starten von Mp3TagsForTracks.  (Gelesen 415 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Terrorizer

  • Neues Foren Mitglied
  • *
  • Beiträge: 32
  • Dankeschön: 1 mal
  • CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 6000+ × 2
  • GPU: Gallium 0.4 on AMD JUNIPER (DRM 2.46.0 / 4.8.0-34-generic, LLVM 3.8.1)
  • Kernel: ?
  • DE: ?
  • GPU Treiber: ?
Fehler beim Starten von Mp3TagsForTracks.
« am: 27. Dezember 2017, 18:10:03 »
...hi an alle; Weihnachten gut überstanden ?

... wollte mir mal das Programm Mp3TagsForTracks https://mp3tagsfortracks.de anschauen & bekomme beim Starten der jar-Datei folgenden Fehler:

java -jar Mp3TagsForTracksv2.2.0.jar
Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" java.lang.UnsupportedClassVersionError: mp3tag/Main has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:467)
at java.net.URLClassLoader.access$100(URLClassLoader.java:73)
at java.net.URLClassLoader$1.run(URLClassLoader.java:368)
at java.net.URLClassLoader$1.run(URLClassLoader.java:362)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:361)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:335)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:495)


...jemand ne Ahnung ? Hab jre9-openjdk  9.u181-4 & jre9-openjdk-headless  9.u181-4 installiert ???
 

gosia

  • Forum Held
  • *****
  • Beiträge: 530
  • Dankeschön: 139 mal
  • CPU: Intel® Core™ i5-3210M
  • GPU: Intel HD 4000
  • Kernel: 4.9. (Artix)
  • DE: OpenBox + xfce
Re: Fehler beim Starten von Mp3TagsForTracks.
« Antwort #1 am: 27. Dezember 2017, 21:23:06 »
Hallo Terrorizer,
...hi an alle; Weihnachten gut überstanden ?
Danke, ja. Fühle mich nur 10 Kg schwerer ;)
... wollte mir mal das Programm Mp3TagsForTracks https://mp3tagsfortracks.de anschauen & bekomme beim Starten der jar-Datei folgenden Fehler:
Hm, kann nicht viel zu Java sagen, aber diese Meldung
Main has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0
bedeutet für mich, daß deine Java Runtime zu alt ist ("erkennt nur class file version bis zu 52.0"), während das Progrämmchen class file version 53.0 benutzt.
Also aufrüsten wenn möglich...

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung...
 

Terrorizer

  • Neues Foren Mitglied
  • *
  • Beiträge: 32
  • Dankeschön: 1 mal
  • CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 6000+ × 2
  • GPU: Gallium 0.4 on AMD JUNIPER (DRM 2.46.0 / 4.8.0-34-generic, LLVM 3.8.1)
  • Kernel: ?
  • DE: ?
  • GPU Treiber: ?
Re: Fehler beim Starten von Mp3TagsForTracks.
« Antwort #2 am: 27. Dezember 2017, 23:30:26 »
... jetzt hab ich was nachinstalliert & jetzt kommt nur noch:

java -jar Mp3TagsForTracksv2.2.0.jar
Fehler: Hauptklasse mp3tag.Main konnte nicht gefunden oder geladen werden
Ursache: java.lang.NoClassDefFoundError: javafx/application/Application
 

Terrorizer

  • Neues Foren Mitglied
  • *
  • Beiträge: 32
  • Dankeschön: 1 mal
  • CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 6000+ × 2
  • GPU: Gallium 0.4 on AMD JUNIPER (DRM 2.46.0 / 4.8.0-34-generic, LLVM 3.8.1)
  • Kernel: ?
  • DE: ?
  • GPU Treiber: ?
Re: Fehler beim Starten von Mp3TagsForTracks.
« Antwort #3 am: 06. August 2018, 19:44:18 »
... mittlerweile mp3tagsfortracks Version 3.1.0. immer noch Fehler:


JarClassLoader: Warning: Null manifest from input stream associated with: lib/jmf-2.1.1e.jar
Exception in thread "main" java.lang.NoClassDefFoundError: javafx/application/Application
at java.base/java.lang.ClassLoader.defineClass1(Native Method)
at java.base/java.lang.ClassLoader.defineClass(ClassLoader.java:1009)
at com.simontuffs.onejar.JarClassLoader.defineClass(JarClassLoader.java:803)
at com.simontuffs.onejar.JarClassLoader.findClass(JarClassLoader.java:710)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:566)
at com.simontuffs.onejar.JarClassLoader.loadClass(JarClassLoader.java:630)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
at com.simontuffs.onejar.Boot.run(Boot.java:334)
at com.simontuffs.onejar.Boot.main(Boot.java:166)
Caused by: java.lang.ClassNotFoundException: javafx.application.Application
at com.simontuffs.onejar.JarClassLoader.findClass(JarClassLoader.java:713)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:566)
at com.simontuffs.onejar.JarClassLoader.loadClass(JarClassLoader.java:630)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
... 9 more

... gestartet wurde mit dem Befehl: java -jar Mp3TagsForTracksv3.1.0.jar
& java-10-openjdk ist aktiv [hab 7 u. 8. auch schon probiert >>> gleicher Fehler]



...keiner ne Idee ???
 

Kunsepp

  • Neues Foren Mitglied
  • *
  • Beiträge: 3
  • Dankeschön: 1 mal
  • CPU: i5-2540M
  • GPU: NVIDIA GF108GLM [Quadro 1000M]
  • Kernel: 4.13
  • DE: Gnome 3
  • GPU Treiber: nvidia
Re: Fehler beim Starten von Mp3TagsForTracks.
« Antwort #4 am: 08. August 2018, 11:51:13 »
Hallo Terrorizer,

Leider keine Ahnung :D

Vielleicht als Alternative: Kid3
Ist in den Repos enthalten

Gruß Kunsepp
 

Terrorizer

  • Neues Foren Mitglied
  • *
  • Beiträge: 32
  • Dankeschön: 1 mal
  • CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 6000+ × 2
  • GPU: Gallium 0.4 on AMD JUNIPER (DRM 2.46.0 / 4.8.0-34-generic, LLVM 3.8.1)
  • Kernel: ?
  • DE: ?
  • GPU Treiber: ?
Re: Fehler beim Starten von Mp3TagsForTracks.
« Antwort #5 am: 08. August 2018, 13:41:29 »
... habs jetzt endlich durch versuchen hinbekommen;

Ich hab einfach folgendes Java Paket nachinstalliert; [jdk  10.0.2-1 / Oracle Java Development Kit] & dieses java als Standard aktiviert mit: [sudo archlinux-java set java-10-jdk]

>>> alles läuft >>> Super !!!