Autor Thema: Ungültiges oder beschädigtes Paket  (Gelesen 143 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Dieses Thema beinhaltet einen Beitrag mit der besten Antwort. Hier drücken um es zu sehen.

Lars

  • Erfahrenes Foren Mitglied
  • **
  • Beiträge: 61
Ungültiges oder beschädigtes Paket
« am: 12. November 2017, 02:38:32 »
Hallo,

ich habe nach langer Zeit wieder mal Probleme, vielleicht lag es an der späteren Aktualisierung.



Gesamtgröße der installierten Pakete:  2772,45 MiB
Größendifferenz der Aktualisierung:    36,84 MiB

:: Installation fortsetzen? [J/n] j
(217/217) Prüfe Schlüssel im Schlüsselring         [######################] 100%
(217/217) Überprüfe Paket-Integrität               [######################] 100%
Fehler: fzf: signature from "Ambrevar <ambrevar@gmail.com>" is unknown trust
:: Datei /var/cache/pacman/pkg/fzf-0.17.1-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] j
Fehler: Konnte den Vorgang nicht durchführen (Ungültiges oder beschädigtes Paket)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.
AMD Phenom II X6 1100T Prozessor, 8,0GB RAM, NVIDIA GeForce GTX 970 XFCE - Edition Kernel 4.4 10-1
 

Blueriver

  • Moderator
  • *****
  • Beiträge: 1004
  • Dankeschön: 108 mal
  • CPU: AMD Quad Core A8 3,6GHz
  • GPU: AMD/ATI Radeon R7
  • Kernel: 4.14
  • DE: XFCE Stable, Testing, Unstable
  • GPU Treiber: Free
Re: Ungültiges oder beschädigtes Paket
« Antwort #1 am: 12. November 2017, 08:43:51 »
Gib erst einmal
sudo rm -r /etc/pacman.d/gnupg
sudo pacman -Sy gnupg archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys

Danach nochmal die Aktuallisierung anstoßen.
Manjaro XFCE Stable, Testing, Unstable
CPU: AMD Quad Core A8 3,6GHz
Graka: AMD/ATI Radeon R7
Treiber: Free
Kernel: 4.14
 

Lars

  • Erfahrenes Foren Mitglied
  • **
  • Beiträge: 61
Re: Ungültiges oder beschädigtes Paket
« Antwort #2 am: 12. November 2017, 12:01:43 »
Hallo Blueriver,

bekam den Fehler, Erforderlicher Schlüssel fehlt im Schlüsselbund

:: Synchronisiere Paketdatenbanken...
 core                     137,3 KiB  1373K/s 00:00 [######################] 100%
 extra                   1762,8 KiB  5,33M/s 00:00 [######################] 100%
 community                  4,4 MiB  5,67M/s 00:01 [######################] 100%
 multilib                 178,9 KiB  6,47M/s 00:00 [######################] 100%
:: Starte vollständige Systemaktualisierung...
Warnung: menulibre: Lokale Version (1:2.1.0-1) ist neuer als community (2.1.3-2)
:: qpdfview-djvu-plugin durch community/qpdfview ersetzen? [J/n] j
:: qpdfview-ps-plugin durch community/qpdfview ersetzen? [J/n] j
:: rfkill durch core/util-linux ersetzen? [J/n] j
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: freetype2 wird vor seiner Abhängigkeit harfbuzz installiert werden
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: mhwd wird vor seiner Abhängigkeit mesa installiert werden

Pakete (220) adwaita-icon-theme-3.26.0-1  alsa-lib-1.1.4.1-2
             appstream-glib-0.7.2-1  apr-1.6.3-1  apr-util-1.6.1-1
             archlinux-appstream-data-20171017-1  archlinux-keyring-20171020-1
             at-spi2-atk-2.26.1-1  at-spi2-core-2.26.2-1  atk-2.26.1-1
             bash-4.4.012-2.2  binutils-2.29.1-1  blueman-2.0.5-1
             ca-certificates-mozilla-3.33-2  celt-0.11.3-3  cmake-3.9.4-1
             cups-2.2.6-1  cups-filters-1.17.9-2  curl-7.56.1-1  dbus-1.12.0-1
             dconf-0.26.1-1  device-mapper-2.02.175-1  dhclient-4.3.6-2
             dnsmasq-2.78-1  downgrade-6.0.0-1  e2fsprogs-1.43.7-1
             ethtool-1:4.13-1  faac-1.29.7.7-1  faad2-2.8.5-1  ffmpeg-1:3.4-1
             fftw-3.3.7-1  filezilla-3.28.0-1  firefox-56.0.2-1
             firefox-i18n-de-56.0.2-1  flashplugin-27.0.0.183-1
             freeglut-3.0.0-2  freetype2-2.8.1-1  fzf-0.17.1-1
             gcc-libs-multilib-7.2.0-3  gcc-multilib-7.2.0-3
             gcr-3.20.0+55+g470bf4c-1  gdk-pixbuf2-2.36.11-1
             ghostscript-9.22-1  git-2.15.0-1  glib-networking-2.54.1-1
             glib2-2.54.2-2  glibc-2.26-5  glibmm-2.54.1-1
             gnome-keyring-1:3.20.1-1  gnome-menus-3.13.3+29+g7f0844e-1
             gnome-themes-standard-3.22.3+13+ga993fdc0-1  gnutls-3.5.16-1
             gobject-introspection-1.54.1-1
             gobject-introspection-runtime-1.54.1-1  gparted-0.30.0-3
             gsettings-desktop-schemas-3.24.1+3+ge869987-1
             gst-libav-1.12.3+1+ge87c20d-1  gtk-update-icon-cache-3.22.25-1
             gtk3-3.22.25-1  gtkmm3-3.22.2+2+g3002ed86-1
             gtksourceview3-3.24.4+11+g190037e9-1  gvfs-1.34.1-1
             gvfs-afc-1.34.1-1  gvfs-gphoto2-1.34.1-1  gvfs-mtp-1.34.1-1
             gvfs-smb-1.34.1-1  harfbuzz-1.6.3-1  harfbuzz-icu-1.6.3-1
             haveged-1.9.1-4  hplip-3.17.10-2  imagemagick-6.9.9.21-1
             inxi-2.3.43-1  json-glib-1.4.2-1  kauth-5.39.0-1
             kcoreaddons-5.39.0-1  kitemmodels-5.39.0-1  krb5-1.15.2-1
             lame-3.100-1  lib32-curl-7.56.1-1  lib32-dbus-1.12.0-1
             lib32-e2fsprogs-1.43.7-1  lib32-freetype2-2.8.1-1
             lib32-gcc-libs-7.2.0-3  lib32-glib2-2.54.2-2
             lib32-libcurl-gnutls-7.56.1-1  lib32-libdrm-2.4.87-1
             lib32-libpng-1.6.34-1  lib32-mesa-17.2.4-1  lib32-p11-kit-0.23.9-1
             lib32-sdl2-2.0.7-1  lib32-systemd-235.38-1  libcups-2.2.6-1
             libcurl-gnutls-7.56.1-1  libdrm-2.4.87-1  libexttextcat-3.4.5-1
             libfilezilla-0.11.0-1  libgadu-1.12.2-4  libgdiplus-4.2-2
             libgksu-2.0.12-8  libgtop-2.38.0+1+g487e584a-2  libgudev-232-1
             libinput-1.8.4-1  libmatroska-1.4.8-1  libmm-glib-1.6.10-1
             libmtp-1.1.14-1  libnl-3.4.0-1  libpciaccess-0.14-1
             libpng-1.6.34-2  libreoffice-still-5.3.7-4  librsvg-2:2.40.19-1
             libsodium-1.0.15-1  libsoup-2.60.2-1  libsynctex-2017.44590-7
             libsystemd-235.38-1  libutil-linux-2.31-1  libuv-1.15.0-1
             libx86emu-1.12-1  libxfont-1.5.3-1  libxfont2-2.0.2-1
             libxres-1.2.0-1  licenses-20171006-1  lightdm-1:1.24.0-1
             lightdm-gtk-greeter-1:2.0.3-1
             lightdm-gtk-greeter-settings-1.2.2-1
             linux-firmware-20171009.bf04291-1  linux41-4.1.45-1
             linux41-ndiswrapper-1.61-8  linux41-nvidia-1:384.90-2
             linux41-r8168-8.044.02-6  lvm2-2.02.175-1
             manjaro-documentation-en-20171027-1  manjaro-hello-0.5.8-1
             manjaro-keyring-20171027-1  manjaro-release-17.0.6-1
             manjaro-settings-manager-0.5.3-7  mesa-17.2.4-1  mhwd-0.6.0-2
             mkinitcpio-24-2  mkinitcpio-busybox-1.27.2-1
             modemmanager-1.6.10-1  mpg123-1.25.7-1  nbd-3.16.2-2
             ncurses-6.0+20170902-2  netctl-1.14-1
             network-manager-applet-1.8.4-2
             networkmanager-openvpn-1.8.1dev+10+ge4d8cda-1
             nm-connection-editor-1.8.4-2  nss-3.33-2  openjpeg2-2.3.0-1
             openssh-7.6p1-1  openssl-1.1.0.g-1  openvpn-2.4.4-1
             p11-kit-0.23.9-1  pacman-mirrors-4.3.1-1  palemoon-bin-27.5.1-1
             pamac-6.2.1-1  pambase-20171006-1  pango-1.40.13-2  parted-3.2-6
             pciutils-3.5.5-1  perl-5.26.1-1  poppler-0.60.1-1
             poppler-glib-0.60.1-1  poppler-qt5-0.60.1-1  ppp-2.4.7-4
             pptpclient-1.9.0-1  protobuf-3.4.1-1  protobuf-c-1.3.0-1
             pulseaudio-ctl-1.66-1  pygobject-devel-3.26.1-1
             pyqt5-common-5.9-2  python-3.6.3-1  python-gobject-3.26.1-1
             python-psutil-5.4.0-1  python-pyqt5-5.9-2
             python-setuptools-1:36.6.0-1  python2-gobject-3.26.1-1
             qpdfview-0.4.17beta1-4.1  qpdfview-djvu-plugin-0.4.16-5 [Entferne]
             qpdfview-ps-plugin-0.4.16-5 [Entferne]  qt5-base-5.9.2-1
             qt5-declarative-5.9.2-2  qt5-multimedia-5.9.2-1  qt5-svg-5.9.2-1
             qt5-tools-5.9.2-1  qt5-x11extras-5.9.2-1  qt5-xmlpatterns-5.9.2-1
             rfkill-0.5-2 [Entferne]  rsync-3.1.2-8  s-nail-14.9.5-1
             sdl2-2.0.7-1  smartmontools-6.5-2  sqlite-3.21.0-1
             steam-manjaro-1.0.0.54-9  systemd-235.38-1
             systemd-sysvcompat-235.38-1  texinfo-6.5-1
             texlive-bin-2017.44590-7  thin-provisioning-tools-0.7.4-1
             thunar-archive-plugin-0.3.1-7  thunderbird-52.4.0-1
             tzdata-2017c-1  util-linux-2.31-1  vlc-2.2.6-4
             vte-common-0.50.2-1  vte3-0.50.2-1  wayland-protocols-1.11-1
             webkit2gtk-2.18.2-1  wget-1.19.2-1  wpa_supplicant-1:2.6-11
             xfce4-genmon-plugin-4.0.1-1  xfce4-notifyd-0.4.0-2
             xfce4-session-4.12.1-7.1  xfce4-weather-plugin-0.8.10-1
             xkeyboard-config-2.22-1  xorg-server-1.19.5-1
             xorg-server-common-1.19.5-1  yelp-3.26.0-1  zenity-3.24.2-1
             zeromq-4.2.2-2

Gesamtgröße des Downloads:              0,77 MiB
Gesamtgröße der installierten Pakete:  2772,45 MiB
Größendifferenz der Aktualisierung:    36,84 MiB

:: Installation fortsetzen? [J/n] j
:: Empfange Pakete...
 fzf-0.17.1-1-x86_64      784,6 KiB  5,89M/s 00:00 [######################] 100%
(217/217) Prüfe Schlüssel im Schlüsselring         [######################] 100%
Warnung: Public keyring not found; have you run 'pacman-key --init'?
Lade benötigte Schlüssel herunter...
Fehler: key "1EB2638FF56C0C53" could not be looked up remotely
Fehler: key "94657AB20F2A092B" could not be looked up remotely
Fehler: key "BBE43771487328A9" could not be looked up remotely
Fehler: key "A5E9288C4FA415FA" could not be looked up remotely
Fehler: key "DAD3B211663CA268" could not be looked up remotely
Fehler: key "A6234074498E9CEE" could not be looked up remotely
Fehler: key "B02854ED753E0F1F" could not be looked up remotely
Fehler: key "4A1AFC345EBE18F8" could not be looked up remotely
Fehler: key "06096A6AD1CEDDAC" could not be looked up remotely
Fehler: key "6D1655C14CE1C13E" could not be looked up remotely
Fehler: key "7F2D434B9741E8AC" could not be looked up remotely
Fehler: key "FC1B547C8D8172C8" could not be looked up remotely
Fehler: key "CAA6A59611C7F07E" could not be looked up remotely
Fehler: key "976AC6FA3B94FA10" could not be looked up remotely
Fehler: key "786C63F330D7CB92" could not be looked up remotely
Fehler: key "7605992471F3F073" could not be looked up remotely
Fehler: key "FCF3C8CB5CF9C8D4" could not be looked up remotely
Fehler: key "7A4E76095D8A52E4" could not be looked up remotely
Fehler: key "B61DBCE10901C163" could not be looked up remotely
Fehler: key "51E8B148A9999C34" could not be looked up remotely
Fehler: key "8DB9F8C18DF53602" could not be looked up remotely
Fehler: key "39E4B877E62EB915" could not be looked up remotely
Fehler: key "AFF5D95098BC6FF5" could not be looked up remotely
Fehler: key "9BDCF497A4BBCC7F" could not be looked up remotely
Fehler: key "771DF6627EDF681F" could not be looked up remotely
Fehler: key "A91764759326B440" could not be looked up remotely
Fehler: key "EEEEE2EEEE2EEEEE" could not be looked up remotely
Fehler: key "C06086337C50773E" could not be looked up remotely
Fehler: key "396E3E25BAB142C1" could not be looked up remotely
Fehler: key "E62F853100F0D0F0" could not be looked up remotely
Fehler: Erforderlicher Schlüssel fehlt im Schlüsselbund
Fehler: Konnte den Vorgang nicht durchführen (Unerwarteter Fehler)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.
« Letzte Änderung: 12. November 2017, 12:03:46 von Lars »
AMD Phenom II X6 1100T Prozessor, 8,0GB RAM, NVIDIA GeForce GTX 970 XFCE - Edition Kernel 4.4 10-1
 

Josef_K

  • Erfahrenes Foren Mitglied
  • **
  • Beiträge: 99
  • Dankeschön: 13 mal
  • CPU: PC Intel i5-4460 - Laptop AMD Phenom II P920
  • GPU: PC GeForce GT 730 - Laptop Ati RS880M
  • Kernel: 4.11 - Openrc
  • DE: XFCE
  • GPU Treiber: PC nonfree - Laptop free
Re: Ungültiges oder beschädigtes Paket
« Antwort #3 am: 12. November 2017, 17:54:47 »
Vielleicht hilft dir das:

sudo pacman -Sy archlinux-keyring manjaro-keyring
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys

https://forum.manjaro.org/c/deutsch
PGV ecogold, HP Pavilion dv7, Raspberry Pi B + 2

Linux is like a Wigwam. No Windows. No Gates. Apache inside
 
Folgende Mitglieder bedankten sich: Lars

Blueriver

  • Moderator
  • *****
  • Beiträge: 1004
  • Dankeschön: 108 mal
  • CPU: AMD Quad Core A8 3,6GHz
  • GPU: AMD/ATI Radeon R7
  • Kernel: 4.14
  • DE: XFCE Stable, Testing, Unstable
  • GPU Treiber: Free
Re: Ungültiges oder beschädigtes Paket
« Antwort #4 am: 12. November 2017, 17:57:16 »
Versuch es mal mit
sudo pacman -Syyuu
evtl. noch den gesamten Cache mit den alten Paketen löschen
sudo pacman -Scc
Manjaro XFCE Stable, Testing, Unstable
CPU: AMD Quad Core A8 3,6GHz
Graka: AMD/ATI Radeon R7
Treiber: Free
Kernel: 4.14
 
Folgende Mitglieder bedankten sich: Lars

Lars

  • Erfahrenes Foren Mitglied
  • **
  • Beiträge: 61
Re: Ungültiges oder beschädigtes Paket
« Antwort #5 am: 13. November 2017, 00:45:37 »
Versuch es mal mit
sudo pacman -Syyuu
evtl. noch den gesamten Cache mit den alten Paketen löschen
sudo pacman -Scc


Das habe ich alles gemacht, leider kam der gleiche Fehler, es sind nur Auszüge, es gab zufiel Zeichen.


:: Starte vollständige Systemaktualisierung...

(218/218) Prüfe Schlüssel im Schlüsselring         [######################] 100%
Warnung: Public keyring not found; have you run 'pacman-key --init'?
Lade benötigte Schlüssel herunter...
Fehler: key "1EB2638FF56C0C53" could not be looked up remotely
Fehler: key "94657AB20F2A092B" could not be looked up remotely
Fehler: key "BBE43771487328A9" could not be looked up remotely
Fehler: key "A5E9288C4FA415FA" could not be looked up remotely
Fehler: key "DAD3B211663CA268" could not be looked up remotely
Fehler: key "A6234074498E9CEE" could not be looked up remotely
Fehler: key "B02854ED753E0F1F" could not be looked up remotely
Fehler: key "4A1AFC345EBE18F8" could not be looked up remotely
Fehler: key "06096A6AD1CEDDAC" could not be looked up remotely
Fehler: key "6D1655C14CE1C13E" could not be looked up remotely
Fehler: key "7F2D434B9741E8AC" could not be looked up remotely
Fehler: key "FC1B547C8D8172C8" could not be looked up remotely
Fehler: key "CAA6A59611C7F07E" could not be looked up remotely
Fehler: key "976AC6FA3B94FA10" could not be looked up remotely
Fehler: key "786C63F330D7CB92" could not be looked up remotely
Fehler: key "7605992471F3F073" could not be looked up remotely
Fehler: key "FCF3C8CB5CF9C8D4" could not be looked up remotely
Fehler: key "7A4E76095D8A52E4" could not be looked up remotely
Fehler: key "B61DBCE10901C163" could not be looked up remotely
Fehler: key "51E8B148A9999C34" could not be looked up remotely
Fehler: key "8DB9F8C18DF53602" could not be looked up remotely
Fehler: key "39E4B877E62EB915" could not be looked up remotely
Fehler: key "AFF5D95098BC6FF5" could not be looked up remotely
Fehler: key "9BDCF497A4BBCC7F" could not be looked up remotely
Fehler: key "771DF6627EDF681F" could not be looked up remotely
Fehler: key "A91764759326B440" could not be looked up remotely
Fehler: key "EEEEE2EEEE2EEEEE" could not be looked up remotely
Fehler: key "C06086337C50773E" could not be looked up remotely
Fehler: key "396E3E25BAB142C1" could not be looked up remotely
Fehler: key "E62F853100F0D0F0" could not be looked up remotely
Fehler: Erforderlicher Schlüssel fehlt im Schlüsselbund
Fehler: Konnte den Vorgang nicht durchführen (Unerwarteter Fehler)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.
AMD Phenom II X6 1100T Prozessor, 8,0GB RAM, NVIDIA GeForce GTX 970 XFCE - Edition Kernel 4.4 10-1
 

Lars

  • Erfahrenes Foren Mitglied
  • **
  • Beiträge: 61
Re: Ungültiges oder beschädigtes Paket
« Antwort #6 am: 13. November 2017, 00:49:27 »
Vielleicht hilft dir das:

Hallo Josef K.

es hat leider nicht geholfen.
Es ist offenbar ein hartnäckiges Problem.



sudo pacman -Sy archlinux-keyring manjaro-keyring
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys

https://forum.manjaro.org/c/deutsch

:: Synchronisiere Paketdatenbanken...
 core                     137,4 KiB  1374K/s 00:00 [######################] 100%
 extra                   1763,9 KiB  5,22M/s 00:00 [######################] 100%
 community                  4,4 MiB  5,70M/s 00:01 [######################] 100%
 multilib                 179,0 KiB  6,72M/s 00:00 [######################] 100%
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...

Pakete (2) archlinux-keyring-20171020-1  manjaro-keyring-20171027-1

Gesamtgröße der installierten Pakete:   0,98 MiB
Größendifferenz der Aktualisierung:  -0,10 MiB

:: Installation fortsetzen? [J/n] j
(2/2) Prüfe Schlüssel im Schlüsselring             [######################] 100%
Warnung: Public keyring not found; have you run 'pacman-key --init'?
Lade benötigte Schlüssel herunter...
Fehler: key "A6234074498E9CEE" could not be looked up remotely
Fehler: key "CAA6A59611C7F07E" could not be looked up remotely
Fehler: Erforderlicher Schlüssel fehlt im Schlüsselbund
Fehler: Konnte den Vorgang nicht durchführen (Unerwarteter Fehler)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.
AMD Phenom II X6 1100T Prozessor, 8,0GB RAM, NVIDIA GeForce GTX 970 XFCE - Edition Kernel 4.4 10-1
 

Lars

  • Erfahrenes Foren Mitglied
  • **
  • Beiträge: 61
Re: Ungültiges oder beschädigtes Paket
« Antwort #7 am: 13. November 2017, 01:19:05 »
Der PC von meiner Signatur hat die Aktualisierung ohne Fehler durchgeführt, es ist nicht zu erkennen warum der kleine PC das nicht zulässt und nach dem Schlüssel fragt.
Da hoffe ich das der Asus und der Lenova nicht auch noch ausfallen.
« Letzte Änderung: 13. November 2017, 01:21:15 von Lars »
AMD Phenom II X6 1100T Prozessor, 8,0GB RAM, NVIDIA GeForce GTX 970 XFCE - Edition Kernel 4.4 10-1
 

Markiert als beste Antwort von Lars am 13. November 2017, 23:24:07

djeli

  • Forum Gott
  • ****
  • Beiträge: 271
  • Dankeschön: 21 mal
  • pssssst
Re: Ungültiges oder beschädigtes Paket
« Antwort #8 am: 13. November 2017, 09:52:23 »
Zitat
Warnung: Public keyring not found; have you run 'pacman-key --init'?

Versuche doch mal
(Der Weg, um an die gültigen Schlüssel zu kommen, wurde durch das Update von pacman auf 4.0.3 vereinfacht)
pacman-key --init erstellt den Schlüsselbund
dann
pacman-key --populate archlinux manjaroSchlüssel holen und Trust Level erstellen
pacman-key --refresh-keysUpdate Schlüsselring

Quelle:https://wiki.archlinux.de/title/Pacman-key
djeli
 
Folgende Mitglieder bedankten sich: Lars

Lars

  • Erfahrenes Foren Mitglied
  • **
  • Beiträge: 61
Re: Ungültiges oder beschädigtes Paket
« Antwort #9 am: 13. November 2017, 23:26:39 »
Hallo djeli,

dass hat geklappt, ich habe der reihe nach die Befehle eingegeben.
Die Aktualisierung läuft gerade.

Viele Dank für die Hilfe.
AMD Phenom II X6 1100T Prozessor, 8,0GB RAM, NVIDIA GeForce GTX 970 XFCE - Edition Kernel 4.4 10-1