Autor Thema: Update mit yaourt schlägt fehl  (Gelesen 1611 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hanisch

  • Neues Foren Mitglied
  • *
  • Beiträge: 16
Update mit yaourt schlägt fehl
« am: 24. August 2016, 21:20:38 »
Hallo,
ich erhalte bei
$ yaourt -Syua --devel
:: Synchronisiere Paketdatenbanken...
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 Fremde Pakete:/ 13 / 13

==> Ausschließlich Paketaktualisierung (neue Ausgabe):
aur/lxqt-admin 0.10.0-0.2 0.2 -> 3

==> Upgrade fortsetzen? [J/n]
==> [P]aketdetails anzeigen [M]anuell Pakete auswählen
==> --------------------------------------------------
==>
...
...
==> Erstelle und installiere Paket
==> Erstelle Paket: lxqt-admin 0.10.0-3 (Mi 24. Aug 21:03:36 CEST 2016)
==> Prüfe Laufzeit-Abhängigkeiten...
==> Prüfe Buildtime-Abhängigkeiten...
==> Empfange Quellen...
  -> Lade lxqt-admin-0.10.0.tar.xz herunter...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   600    0   600    0     0    986      0 --:--:-- --:--:-- --:--:--   985
100 29364  100 29364    0     0  18306      0  0:00:01  0:00:01 --:--:--  103k
  -> Lade lxqt-admin-0.10.0.tar.xz.asc herunter...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   605    0   605    0     0   1047      0 --:--:-- --:--:-- --:--:--  1048
100   949  100   949    0     0    813      0  0:00:01  0:00:01 --:--:--  2719
==> Überprüfe source Dateien mit sha256sums...
    lxqt-admin-0.10.0.tar.xz ... Durchgelaufen
    lxqt-admin-0.10.0.tar.xz.asc ... Übersprungen
==> Überprüfe Signaturen der Quell-Dateien mit gpg...
    lxqt-admin-0.10.0.tar.xz ... FEHLGESCHLAGEN (Unbekannter öffentlicher Schlüssel 37E0AF1FDA48F373)
==> FEHLER: Eine oder mehrere PGP-Signaturen konnten nicht überprüft werden!
==> FEHLER:Makepkg konnte lxqt-admin nicht erstellen.
==> Erstellen von lxqt-admin neu starten?[j/N]
==> ------------------------------------------
0.tar.xz ... FEHLGESCHLAGEN (Unbekannter öffentlicher Schlüssel 37E0AF1FDA48F373)
==> FEHLER: Eine oder mehrere PGP-Signaturen konnten nicht überprüft werden!
==> FEHLER:Makepkg konnte lxqt-admin nicht erstellen.
==> Erstellen von lxqt-admin neu starten?[j/N]
==> ------------------------------------------
Offensichtlich ist das PKGBUILD fehlerhaft.

Weiterhin stelle ich noch einen Fehler bei xfce4-whiskermenu-plugin-git fest:
$ yaourt -S  xfce4-whiskermenu-plugin-git

==> Lade PKGBUILD von xfce4-whiskermenu-plugin-git aus dem AUR herunter...
x .SRCINFO
x .gitignore
x PKGBUILD
x xfce4-whiskermenu-plugin-git.install
killermoehre commented on 2015-02-05 10:35
This package is broken, because it tries to install stuff into /usr/lib64, which is forbidden. Please change the install path to /usr/lib. Thank you very much.

zegoti commented on 2015-02-17 13:52
Please update the package with:  -DCMAKE_INSTALL_LIBDIR='/usr/lib'
after: -DCMAKE_INSTALL_PREFIX=/usr

Alad commented on 2016-04-09 16:50
There's no need to have the PKGBUILD and .install file executable, as they're sourced by makepkg, and run with /bin/sh by pacman, respectively.

xfce4-whiskermenu-plugin-git 1.5.0.12.gaf5e8-1  (2015-06-08 18:27)
(Nicht unterstütztes Paket: Potenziell gefährlich!)
==> PKGBUILD bearbeiten? [J/n] („A“ zum Abbrechen)
==> ----------------------------------------------
==> n

==> Von xfce4-whiskermenu-plugin-git benötigt:
 - xfce4-panel (bereits installiert)
 - cmake (bereits installiert) [makedepend]
 - git (bereits installiert) [makedepend]


==> xfce4-whiskermenu-plugin-git.install bearbeiten? [J/n] („A“ zum Abbrechen)
==> --------------------------------------------------------------------------
==> n

==> Mit dem Erstellen von xfce4-whiskermenu-plugin-git fortfahren?[J/n]
==> -------------------------------------------------------------------
==>
...
CMake Error at /usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:424 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake-3.6/Modules/FindPkgConfig.cmake:597 (_pkg_check_modules_internal)
  panel-plugin/CMakeLists.txt:17 (pkg_check_modules)


-- Configuring incomplete, errors occurred!
See also "/tmp/yaourt-tmp-opa/aur-xfce4-whiskermenu-plugin-git/src/xfce4-whiskermenu-plugin/CMakeFiles/CMakeOutput.log".
==> FEHLER: Ein Fehler geschah in build().
    Breche ab...
==> FEHLER:Makepkg konnte xfce4-whiskermenu-plugin-git nicht erstellen.
==> Erstellen von xfce4-whiskermenu-plugin-git neu starten?[j/N]
==> ------------------------------------------------------------
==>


Was kann man da machen?

Gruß
Ch. Hanisch

« Letzte Änderung: 24. August 2016, 21:40:12 von Hanisch »
 

gosia

  • Forum Gott
  • ****
  • Beiträge: 348
  • Dankeschön: 55 mal
  • CPU: Intel® Core™ i5-3210M
  • GPU: Intel HD 4000
  • Kernel: 4.9. (OpenRC)
  • DE: OpenBox + xfce
Re: Update mit yaourt schlägt fehl
« Antwort #1 am: 24. August 2016, 23:43:05 »
Hallo Ch. Hanisch,
    lxqt-admin-0.10.0.tar.xz ... FEHLGESCHLAGEN (Unbekannter öffentlicher Schlüssel 37E0AF1FDA48F373)
Was kann man da machen?
Den Schlüssel importieren:
gpg --keyserver eu.pool.sks-keyservers.net --recv-keys DA48F373https://aur.archlinux.org/packages/lxqt-admin/
dort der Kommentar von "tastyminerals commented on 2016-05-16 12:41"

Viele Grüße gosia

PS. Für das zweite Problem vielleicht besser einen neuen Thread aufmachen, wird sonst etwas unübersichtlich.

Meinen eigenen worten zum Trotz, zum zweiten Problem: Muss xfce4-whiskermenu-plugin unbedingt aus dem AUR sein, gibt es auch in community:
sudo pacman -S xfce4-whiskermenu-plugin
« Letzte Änderung: 24. August 2016, 23:49:41 von gosia »
"funktioniert nicht" ist keine brauchbare Fehlermeldung...
 
Folgende Mitglieder bedankten sich: Hanisch

Hanisch

  • Neues Foren Mitglied
  • *
  • Beiträge: 16
Re: Update mit yaourt schlägt fehl
« Antwort #2 am: 25. August 2016, 11:54:21 »

den Schlüssel importieren:
gpg --keyserver eu.pool.sks-keyservers.net --recv-keys DA48F373https://aur.archlinux.org/packages/lxqt-admin/
dort der Kommentar von "tastyminerals commented on 2016-05-16 12:41"
Hat funktioniert - Danke.

Zitat
Muss xfce4-whiskermenu-plugin unbedingt aus dem AUR sein, gibt es auch in community:
sudo pacman -S xfce4-whiskermenu-plugin
Habe xfce4-whiskermenu-plugin installiert und  xfce4-whiskermenu-plugin-git gelöscht.
Mal sehen, ob das auch funktioniert.

Gruß
Ch. Hanisch
 

Hanisch

  • Neues Foren Mitglied
  • *
  • Beiträge: 16
Re: Update mit yaourt schlägt fehl
« Antwort #3 am: 02. August 2017, 16:24:05 »
Hallo,

den Schlüssel importieren:
gpg --keyserver eu.pool.sks-keyservers.net --recv-keys DA48F373https://aur.archlinux.org/packages/lxqt-admin/
dort der Kommentar von "tastyminerals commented on 2016-05-16 12:41"
Hat funktioniert - Danke.
Leider habe ich schon wieder ein ähnliches Problem bei
yaourt -S python3-aur
...
==> Überprüfe Signaturen der Quell-Dateien mit gpg...
    python3-aur-2017.7.tar.xz ... FEHLGESCHLAGEN (Unbekannter öffentlicher Schlüssel 1D1F0DC78F173680)

$ gpg --keyserver eu.pool.sks-keyservers.net --recv-keys 8F173680
gpg: WARNUNG: Unsichere Zugriffsrechte des Home-Verzeichnis `/home/opa/.gnupg'
gpg: Schlüssel 1D1F0DC78F173680: "Xyne. (key #3) <xyne@archlinux.ca>" nicht geändert
gpg: Anzahl insgesamt bearbeiteter Schlüssel: 1
gpg:                             unverändert: 1
Damit funktioniert es nun wieder.
Was könnten das für unsichere Zugriffsrechte sein?

Gruß
Ch. Hanisch


 

gosia

  • Forum Gott
  • ****
  • Beiträge: 348
  • Dankeschön: 55 mal
  • CPU: Intel® Core™ i5-3210M
  • GPU: Intel HD 4000
  • Kernel: 4.9. (OpenRC)
  • DE: OpenBox + xfce
Re: Update mit yaourt schlägt fehl
« Antwort #4 am: 02. August 2017, 19:32:54 »
Hallo Ch. Hanisch,
gpg: WARNUNG: Unsichere Zugriffsrechte des Home-Verzeichnis `/home/opa/.gnupg'

Was könnten das für unsichere Zugriffsrechte sein?
Wahrscheinlich ist das Verzeichnis /home/opa/.gnupg für alle Welt les- und/oder zugreifbar. Möglicherweise die zugehörigen Unterverzeichnisse ebenfalls. Um das zu korrigieren, gib mal folgenden Befehl ein
find /home/opa/.gnupg -type d -exec chmod 700 {} \;
Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung...
 
Folgende Mitglieder bedankten sich: Hanisch

Hanisch

  • Neues Foren Mitglied
  • *
  • Beiträge: 16
Re: Update mit yaourt schlägt fehl
« Antwort #5 am: 02. August 2017, 19:40:39 »
Hallo,
Hallo Ch. Hanisch,
gpg: WARNUNG: Unsichere Zugriffsrechte des Home-Verzeichnis `/home/opa/.gnupg'

Was könnten das für unsichere Zugriffsrechte sein?
Wahrscheinlich ist das Verzeichnis /home/opa/.gnupg für alle Welt les- und/oder zugreifbar. Möglicherweise die zugehörigen Unterverzeichnisse ebenfalls. Um das zu korrigieren, gib mal folgenden Befehl ein
find /home/opa/.gnupg -type d -exec chmod 700 {} \;
Ja, das war's - Danke!

Gruß
Ch. Hanisch